Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a CentOS server with a plesk control panel installed, I used to login using SFTP with the root password to manage the files. However, and all of a sudden, I am not able to access the server using SFTP and I get this error when using CuteFTP

ERROR:>     [4/18/2012 5:18:31 PM] Connection to the server was lost, and the operation could not be performed.
ERROR:>     [4/18/2012 5:18:31 PM] Can't connect to SFTP21 error = #7. 0

I tried restarrting sshd on linux but with no luck, how do I troubleshoot this?

Appreciate the help.

Yehia A.Salam

share|improve this question
Does CUTE have an option for SCP fallback? Might want to give that a try if it exists. – Tim Apr 18 '12 at 15:29
Can you login via ssh? Do you have an IPS tool installed? (denyhost/fail2ban) – Zoredache Apr 18 '12 at 15:39
yes I can login through ssh, Actually I tried WinSCP (CuteFTP does not have a SCP fallback) and It worked. But why in the first place the sftp is not working. – Yehia A.Salam Apr 19 '12 at 15:29
up vote 0 down vote accepted

I tried WinSCP and it works now, however i'm not sure why in the first place the sftp was not working

share|improve this answer

You've answered your own question, but it's good to know why things fail. might help. WinSCP is excellent, I'd use that over CuteFTP but I have a strong bias against FTP in general. You might also want to check out lftp, an awesome command-line s/ftp client.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.