Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using a http://bitnami.org installation of TRAC.

The issue I have is similar to this one but Apache will only sometimes deliver the trac.css (/trac/PROJECT/chrome/common/css/trac.css) as text/plain instead of text/css.

When it does the CSS is not accepted by Chrome and the site will look broken. After clearing the browser cache it loads normally.

The issue is very hard to track down because most of the time it works and fails only 'every other day'.

Any ideas on how to fix this or why it is happening? I'm no Apache expert - that's why I'm using the standard Bitnami stack.

Apache 2.2.21, TRAC 0.12 on Windows 2008


@shane: the Chrome developer tools list trac.css as text/plain when the site looks broken (when the css is not applied). After refreshing it shows text/css in the dev. tools. That's the only difference I could find.

share|improve this question
    
Are you certain that that's the only issue with the content on broken responses? Chrome should load it as a stylesheet just fine regardless of the MIME type being text/plain or application/octet-stream. Confirm with Chrome's developer tools. –  Shane Madden Apr 19 '12 at 2:34

1 Answer 1

up vote 2 down vote accepted

Turns out this is a known issue in mod_wsgi.

http://trac.edgewall.org/ticket/10675

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.