Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Problem: \\computername\c$ returns "Network Name cannot be found"

I tried using \\computername\c$ as well as well as with the FQDN \\computername.domain.company.com\c$ and the IP address too.

net use * \computername\c$ /user AdminprivilegedUser --> returns "The network name cannot be found"

Computer's in question:

  1. WinXPSp2x86 (part of us.company.com on corporate network)
  2. WinVistaSp2x86 (part of us.company.com on corporate network)
  3. WinServer2003SPx86 (part of uk.company.com on corporate network) - \\computername\c$ -> works!
  4. #1WinServer2008R2SP1x64 (part of uk.company.com on corporate network) - \\computername\c$ -> works!
  5. #2WinServer2008R2SP1x64 (part of uk.company.com on corporate network) - \\computername\c$ -> doesnt work

[WinServer2003SPx86, #1WinServer2008R2SP1x64 are production servers, #2WinServer2008R2SP1x64 is a staging server]- in case that helps in any information

The computer (client) I am using to access the shares is WinVistaSp2x86.

Edit: Updated with more details

\\WinXPSp2x86 -- lists shared files. \\WinXPSp2x86\c$ -- returns network name not found [UAC - Not applicable | HKLM..LanmanServer.. Autoserver key unavailable]

\\WinVistaSp2x86 -- lists shared files. \\WinVistaSp2x86\c$ -- returns network name not found [UAC - Off | HKLM..LanmanServer.. Autoserver key unavailable]

\\WinServer2003SPx86 -- lists shared files. \\WinServer2003SPx86\c$ -- works! [UAC - Notify me only when programs try to make changes to my computer | HKLM..LanmanServer.. Autoserver key set to 1]

\\#1WinServer2008R2SP1x64 -- lists shared files. \\#1WinServer2008R2SP1x64\c$ -- works! [UAC - Notify me only when programs try to make changes to my computer | HKLM..LanmanServer.. Autoserver key set to 1]

\\#2WinServer2008R2SP1x64 -- lists shared files. \\#2WinServer2008R2SP1x64\c$ -- returns network name not found [UAC - Notify me only when programs try to make changes to my computer | HKLM..LanmanServer.. Autoserver key set to 1]

if I RDP to this 2008 server, and try \\localhost or \\localhost\c$ it shows me the share. However if I do \\servername or \\servername\c$ it would give me a credential prompt window saying 'logon failure or bad password'

I am trying to understand what makes this differenciation between a #1WinServer2008R2SP1x64 and a #2WinServer2008R2SP1x64.

  • User Access Control is turned off. (wherever applicable on the above list of computers)
  • File and Printer sharing for Microsoft Networks is enabled on the Network Properties on all computers.
  • All the computers (as mentioned above) does show their shared files when accessed using \\computername. [They show the shared folders that are located accross multiple drives (C, D, E, F) on the computer.]
  • User account used to access all these shares is a part of Administrator group across all these computers.
  • Firewall? I dont think it a problem here, since I am able to access the files shared on all these computers and what I am not able to access is the default administrator shares.

  • (more information? will be posted on request as I have posted everything related that Iam aware of)

Expected Solution: I want to be able to access the administrator shares across all the above computers. I want to be able to browse the hard drives in those computers via their driverletter$ syntax.

May be I am not understanding how an Administrator share is configured by the operating system or the changes that happen to file sharing when a computer joins a domain. I have tried my best to explain the situation, please request for more information if anything is vague.

I am not an IT Administrator, I do not manage any of them, I am a Developer that mananges applications deployed accross all these servers.

I have provided a subset of the servers, I do have more servers that my application runs on and I want to be able to access all of them using their administrative shares, and I dont want to manually share a particular folder for a particular user or for Aministrator's group, because the folder that I might access may vary. And I dont want to explicitly share an entire drive partition on a server as my IT Administrators will hate it as a prohibited activity. While I do understand their concers, I dont understand how that Administrator share work in some computers (including the production ones).

[Edit: Posting Solution]

tweaking the autoshareserver key on servers and autosharewks key on workstations under the registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\ enabled the default hidden admin share on the servers and workstations.

After setting this registry key value to 1, I had to restart the LanmanServer to view the admin shares.

For disabling them, after setting the registry key value to 0, I had to restart the Lanman server to see the changes.

However for disabling admin shares on the WinVistaSp2x86 workstations, after setting the autosharewks to 0 and restarting lanman server, I had to manually disconected these admin shares from 'compmgmt.msc' | System Tools| Shared Folders| Shares to disconected the admin shares and disable them. Else they kept showing up.

Thanks everyone for paying attention to way too many details on this question.

share|improve this question
1  
What is the OS version of the client you are connecting from? If you RDP to the 2003, and login as your admin account, can you browse the admin shares from there? Is UAC disabled on the client trying to connect? –  Zoredache Apr 18 '12 at 18:29
    
there is a specific share called admin$ does that work? –  tony roth Apr 18 '12 at 19:13
    
WinVistaSp2x86 is my client. admin share works on the 2003 and another 2008. But on another 2008, admin shares dont work. When I RDP to that 2008 and try to browse the admin share, it gives me the Enter credentials prompt. makes me doubt the UAC setting on that machine. Let me double check and update the question. Thanks for the probing. appreciate that. –  gmaran23 Apr 18 '12 at 19:25
1  
Did you get into the ones that don't work, look in Computer Management, and verify that the $ administrative shares are there under "Shares"? –  TheCleaner Apr 18 '12 at 20:51
1  
ok so on a post vista devices run the command prompt as admin then do the following "dir \\#2WinServer2008R2SP1x64\c$" what happens. –  tony roth Apr 19 '12 at 13:20

1 Answer 1

up vote 1 down vote accepted

Administrative shares can be disabled in the registry. This is typically done via group policy in a domain. Check the following key on the boxes that you cannot get to.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Key is called AutoShareServer. If it is 0, admin shares are disabled.

share|improve this answer
    
and if this is the case then these servers quite naturally are spread among many different ou's with this set differently, ouch no fun. –  tony roth Apr 18 '12 at 19:11
    
@Paul Ackerman question updated with AutoShareServer details. Can you take a look st the #2 windows 2008 server. If has AutoShareServer at LanmanServer set to 1. But RDP-ing to the server \\localhost works, but \\servername (while I am still RDP-ed on that server) does not work. it says login failure or bad password. Should I be checking something else? –  gmaran23 Apr 18 '12 at 20:44
    
@Paul Ackerman HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\ autoshareserver and autosharewks on server (server 2003 and 2008) and workstation (Vista and XP) did the trick. Setting these registry keys to 1 enabled the hidden administrator shares. However that (access denied/bad password) seems to be relating to another issue for which Iam gonna get in touch with IT. That apart, in all other workstations and servers, setting the aforementioned keys to 1 does the trick. on post vista systems UAC disabling makes a difference. Thanks! –  gmaran23 Apr 19 '12 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.