Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem setting up IPv6 connectivity to two virtual hosts that I run on VmWare workstation. The hosts are CentOS 6.2 x86 and x86-64. Even though they are on a bridged network and there is a RA router on the same segment, they don't accept the advertisment from the router.

I can ping6 the router through its link-local address, cat /proc/sys/net/ipv6/conf/eth0/accept_ra returns 1 and I flushed all the ip6tables rules.

The hosts are both a fresh install and I haven't changed anything apart from installing a few libraries and changing wallpaper ;)

What should I do/check/... ?

share|improve this question
1  
Is /proc/sys/net/ipv4/ip_forward enabled in the VM? If so, then the system will not automatically assign an address. –  Zoredache Apr 18 '12 at 18:50
    
Well, it was set to 1. I will try to disable forwarding and try again. –  Tibor Apr 18 '12 at 18:54
    
That is strange /proc/sys/net/ipv4/ip_forward shows 1, even though in sysctl.conf there is set net.ipv4.ip_forward = 0. How is this possible? –  Tibor Apr 18 '12 at 19:07
    
I know many firewall scripts/tools will enable forwarding for you even if you are just setting up host-based rules. Try doing something like this grep forward /etc/*. You might be able to find what is setting it. –  Zoredache Apr 18 '12 at 19:18
    
Nope, grep does not return anything connected to IP forwarding. –  Tibor Apr 18 '12 at 19:32

1 Answer 1

up vote 1 down vote accepted

Here is the relavent bits from the kernel documentation about forwarding. And Router Solicitations/Advertisements.

forwarding - BOOLEAN
        Configure interface-specific Host/Router behaviour.

        Note: It is recommended to have the same setting on all
        interfaces; mixed router/host scenarios are rather uncommon.

        FALSE:

        By default, Host behaviour is assumed.  This means:

        1. IsRouter flag is not set in Neighbour Advertisements.
        2. Router Solicitations are being sent when necessary.
        3. If accept_ra is TRUE (default), accept Router
           Advertisements (and do autoconfiguration).
        4. If accept_redirects is TRUE (default), accept Redirects.

        TRUE:

        **If local forwarding is enabled, Router behaviour is assumed.**
        This means exactly the reverse from the above:

        1. IsRouter flag is set in Neighbour Advertisements.
        2. **Router Solicitations are not sent.**
        3. **Router Advertisements are ignored.**
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.