Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have VirtualHost with DocumentRoot "/home/blogs/domain.com"

<VirtualHost domain.com:80>
 ServerName domain.com
 ServerAlias www.domain.com
 ServerAdmin admin@domain.com
 DocumentRoot "/home/blogs/domain.com"
 <Directory "/home/blogs/domain.com">
  AllowOverride All
  Allow from All
 </Directory>
</VirtualHost>

I'm getting error [Thu Apr 19 02:37:15 2012] [crit] [client 12.13.14.15] (13)Permission denied: /home/blogs/.htaccess pcfg_openfile: unable to check htaccess file

I have the following rights...

/home/blogs/ drwx------ (0700)

/home/blogs/domain.com/ drwxrwxr-x (0775)

Do I have to add blogs user to apache group? How can I do it?

PS: Why apache is looking for .htaccess file at /home/blogs/, but DocumentRoot is /home/blogs/domain.com

Thank you.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Given the permissions of /home/blogs/, only the owner of the directory can see the contents. you may want to grant 750 or 755 permissions, so apache could read the contents.

The reason its looking for a /home/blogs/.htaccess file is a configuration option you haven't shown from your configs. It is probably a <Directory /> AllowOverride ...</Directory>.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.