Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have registered an .au.com domain name with a domain provider here in Australia and have created successfully a Google Apps email account using the domain (Google Apps have confirmed my MX records are correct and I have received test emails from .COM.AU addresses as well as from GMAIL.COM addresses). However, upon opening a Disqus and Twitter account using that email address I'm having difficulty receiving emails from those organisations. This has been a problem that has persisted over the last couple of days.

When I dig rs.au.com on my terminal I receive the following information:

; <<>> DiG 9.7.3-P3 <<>> rs.au.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58329
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 0

;; QUESTION SECTION:
;rs.au.com.         IN  A

;; ANSWER SECTION:
rs.au.com.      300 IN  A   184.169.142.209

;; AUTHORITY SECTION:
rs.au.com.      172800  IN  NS  ns-357.awsdns-44.com.
rs.au.com.      172800  IN  NS  ns-642.awsdns-16.net.
rs.au.com.      172800  IN  NS  ns-1434.awsdns-51.org.
rs.au.com.      172800  IN  NS  ns-1581.awsdns-05.co.uk.

;; Query time: 197 msec
;; SERVER: XXXXXXXXXXXXX
;; WHEN: Thu Apr 19 10:07:35 2012
;; MSG SIZE  rcvd: 180

And when I dig rs.au.com through an EC2 US instance I receive the following information:

; <<>> DiG 9.7.3 <<>> rs.au.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 4929
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;rs.au.com.         IN  A

;; AUTHORITY SECTION:
au.com.         180 IN  SOA ns4.au.com. postmaster.mail.au.com. 2012032205 7200 1800 604800 21600

;; Query time: 20 msec
;; SERVER: XXXXXXXXXXXXX
;; WHEN: Thu Apr 19 00:07:42 2012
;; MSG SIZE  rcvd: 83

Could the problem I'm having with receiving emails from Disqus and Twitter be due to the conflict of the Authority Section as shown above?

Thanks for any help, Ryan

PS - I have checked "Spam" folder and no emails are there.

EDIT (21/04/12):

I still appear to be having some problems with receiving email even after consulting with my domain registrar who state that everything is fine on their end. They ran the following command on their terminal and I received the following reply:

dig ns rs.au.com @ns1.au.com =

; <<>> DiG 9.7.3 <<>> ns rs.au.com @ns1.au.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57379
;; flags: qr rd; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;rs.au.com.                     IN      NS

;; ANSWER SECTION:
rs.au.com.              180     IN      NS      ns-1434.awsdns-51.org.
rs.au.com.              180     IN      NS      ns-1581.awsdns-05.co.uk.
rs.au.com.              180     IN      NS      ns-357.awsdns-44.com.
rs.au.com.              180     IN      NS      ns-642.awsdns-16.net.

;; Query time: 4 msec
;; SERVER: 203.55.143.11#53(203.55.143.11)
;; WHEN: Fri Apr 20 08:16:50 2012
;; MSG SIZE  rcvd: 164

   Both those name servers do not show NXDOMAIN in the status. It could
be the resource record cached in the isp at that end. You can attempt to
re-delegate the name servers again, but if it is a caching issue then
re-delegating may not help. I have also pinged those nameservers and
they are pinging.

I then tried resetting the nameservers and even upon doing that I still have problems with receiving email from Twitter, Akismet (etc).

Any ideas?

share|improve this question
    
.com.au or .au.com? –  DerfK Apr 19 '12 at 1:26
    
Hi DerfK, my domain is rs.au.com –  rs77 Apr 19 '12 at 3:56

1 Answer 1

up vote 3 down vote accepted

The au.com domain has two nameservers that serve it. One (ns4.au.com) correctly handles your domain. The other (ns1.au.com) does not. I would talk to the folks at au.com if it's been more than a day or two.

From ns1.au.com:

  ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 27330

  ;; QUESTION SECTION:
  ;rs.au.com.                     IN      NS

But from ns4.au.com:

  ;; QUESTION SECTION:
  ;rs.au.com.                     IN      NS

  ;; ANSWER SECTION:
  rs.au.com.              180     IN      NS      ns-357.awsdns-44.com.
  rs.au.com.              180     IN      NS      ns-642.awsdns-16.net.
  rs.au.com.              180     IN      NS      ns-1581.awsdns-05.co.uk.
  rs.au.com.              180     IN      NS      ns-1434.awsdns-51.org.

The issue is the NXDOMAIN, not the different authority.

share|improve this answer
    
Thanks for your help David. I initially asked my registrar about this problem and they said the nameserver settings were correctly pointing to mine. I'll follow them up re: ns1.au.com. Will keep you posted. Thanks again! –  rs77 Apr 19 '12 at 4:54
    
According to my domain provider there are no problems with the ns1.au.com domain pointing to my nameservers (as demonstrated with their correspondence which I've added to my initial post above). I've reset my nameservers and acquired new ones and I still seem to be having the problem. –  rs77 Apr 20 '12 at 22:41
    
At least for me, right now, ns1.au.com appears to be dead. That's better than it returning nonsense. However, they really need to get their act together. Right now they only have one functional nameserver and it seems like it took them an awfully long time to notice that the other one was returning junk. –  David Schwartz Apr 20 '12 at 22:46
    
I'm glad I'm not alone. When I run the same command dig ns rs.au.com @ns1.au.com = on my terminal I also get a dead response. How were they able to get a response? I'll go back to them again. Thanks David! –  rs77 Apr 20 '12 at 22:59
1  
As a FINAL update, the emails are now working from Twitter. I guess I just had to wait for everything to propagate. Thanks again for your help David!! –  rs77 Jun 9 '12 at 7:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.