Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Apache/2.2.17 on ubuntu 11.4(64bit) ,with 48 GB of RAM, and set

KeepAlive ON
MaxKeepAliveRequests 100
keepalivetimeout to 6 (since  lot of dynamic images) 
StartServers          100
MinSpareServers       100
MaxSpareServers       150
ServerLimit           300
MaxClients            300
MaxRequestsPerChild   3000

But the problem is Apache is usually reaching its max-clients even with 10-20 users,and after restart its reaching near to 185 with in first 10-15 minutes and not coming down.Can anyone help in finding the reason for it..

share|improve this question

1 Answer 1

Without knowing fully what is going on with your system when this happens (see below), here are a couple of suggestions:

  1. First, lower your start servers to something like 10, and same for MinSpare and MaxSpare. The high numbers you have might be eating up your memory when the web server starts up.

  2. Second, try setting your MaxKeepAliveRequests to a high value: http://httpd.apache.org/docs/2.0/mod/core.html#maxkeepaliverequests . The default is 100, so try increasing in increments of 100 (or any number you find suitable), and see if get to a sweet spot. You can also try 0, for "unlimited amount."

Also, update your question with what the system is doing when this happens. It is out of memory and swapping (free -m)? Is the CPU pegged? What do you see out of top? What else are you running on this box?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.