Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Good day,

I am trying to install Oracle Database in Oracle Linux. However, it is looking for some dependencies. Anybody knows where I can get them?

Package: gcc-3.4.6  FAILED  
Package: libaio-0.3.105 FAILED  
Package: glibc-2.3.4-2.41   FAILED  
Package: compat-libstdc++-33-3.2.3  FAILED  
Package: compat-libstdc++-33-3.2.3  FAILED  
Package: elfutils-libelf-devel-0.97 FAILED  
Package: glibc-devel-2.3.4  FAILED  
Package: glibc-headers-2.3.4    FAILED  
Package: gcc-c++-3.4.6  FAILED  
Package: libaio-devel-0.3.105   FAILED  
Package: libaio-devel-0.3.105   FAILED  
Package: libgcc-3.4.6   FAILED  
Package: libstdc++-3.4.6    

See screenshot here : http://snag.gy/gwCFB.jpg

Thanks,

Franz

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Oracle docs?

https://blogs.oracle.com/linux/entry/oracle_rdbms_server_11gr2_pre

So, something like yum install oracle-rdbms-server-11gR2-preinstall. Some other discussion notes that they may have changed the package name with Oracle Linux 6.x, with the previous name as oracle-validated. I'm sure that there are other Oracle RDBMS installation notes somewhere on their site.

share|improve this answer
    
That's that worked! :) Although after installing the oracle-rdbms-server-11gR2-preinstall, I still had some warnings from the oracle db installer about missing dependencies, the packages are already there actually but not the same version (most of them are just slightly different). So I just ignored it and now it works. Thanks! –  Franz See Apr 21 '12 at 6:29

The easiest way is to try to install them using the package manager of your distribution.

Under Debian-based systems (like Debian and Ubuntu), you can apt-cache search and apt-get install.

Under redhat-based systems (like Redhat, Fedora, and CentOS), you can use yum search and yum install.

You have to be careful about packages' versions. If they don't meet the required packages, you have troubles later.

If you failed to find a proper package in your package manager, you can try to search for one on the web. If you could not get one, you will need to install it from source.

share|improve this answer
    
Oracle Linux is RedHat, only with Oracle logo... –  Jan Marek Apr 19 '12 at 9:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.