Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have an Oracle VM Cluster that we are provisioning on a Cisco UCS B series blade chassis. It has 2 fabric interconnects (FC0 and FC1) provisioned to the (3) Oracle VM service profiles and it is set to boot from san with no local storage configured at all. The issue is that each time we reboot the Oracle VM Server, there is about an 80% chance that it will result in the below errors. I have been able to boot all three service profiles up at the same time with no issue at least three times throughout this process.

Setting up Logical Volume Management: /dev/sdq: open failed: No medium found /dev/sdp: open failed: No medium found

Checking filesystems fsck.ext3: Unable to resolve 'UUID=39b6935d-5c93-45aa-b54d-344fa171c40c'

This drops me to a 'Repair filesystem' prompt where a fsck gives me the same error. I am able to mount this uuid and view the data (from withing the Repair filesystem). Running 'blkid' shows that the boot partition and erroring partition's UUIDs match and they are mapped exactly between grub.conf and /etc/fstab.

As a test, I just zoned the fabric switches back to Single initiator, single target for this service profile, but this has provided no positive movement. Are there zoning or specific UCS service profile requirements that need to be met in order to boot from san with Oracle VM? Any help would be appreciated.


share|improve this question
Good question- I had the same problem with a linux VM during an eval of UCS. We never bothered going forward (for a host of other reasons) and never figured out why boot from san worked under windows and redhat but not oracle vm. I look forward to seeing the answers. – Jim B Apr 19 '12 at 15:31
up vote 2 down vote accepted

It looks like multi pathing boot from SAN is not supported in Oracle VM 3.0.3.

It seems like there are ways to get booting form SAN without multipathing working using iSCSI and I believe FC should work as well.

Here is a thread on Oracle's forumns that talks about this issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.