Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When remoting into 2008 R2 we are getting this message.

Remote Desktop cannot verify the identity of the remote computer because there is a time or date difference between your computer and the remote computer. Make sure your computer's clock is set to the correct time, and then try connecting again.

I have checked the server and the time is correct.

Checking the event logs it is saying The RPC server is unavailable I'm not sure if this is related.

Additional note: We have Nagios monitoring, and it has reported Result from smbclient not suitable.

share|improve this question
2  
You said you checked the server but what about the client? The time on the server and client need to be close to each other (I believe within 5 minutes though I'm willing to be corrected) for the kerberos authentication to work. –  webtoe Apr 20 '12 at 10:13
    
Hi. The client's time is correct also. –  Matt Apr 20 '12 at 10:18
    
Restarting the server, solved the issue. –  Matt Apr 23 '12 at 9:03

2 Answers 2

up vote 0 down vote accepted

Restarting the server and installing all of the latest updates solved the issue.

share|improve this answer
1  
Of course it did, it's Windows! ;-P –  Dave Forgac May 21 '12 at 14:50
    
+1 worked for me also (although no new updates were needed). –  Jonathan Apr 4 '13 at 17:33
1  
In my case, using the IP address instead of the machine name did the trick. It's a workaround though. –  Matias Feb 12 '14 at 15:28

A little old but there are several other options for this issue like DNS issues... please take a look at this link:

http://www.chicagotech.net/remoteissues/rdc4.htm

In my case, it is DNS issue. After we moved one Hyper-V VM from one physical server to another physical server, we receive this error: "Your computer could not connect to another console session on the remote computer because you already have a console session in progress." If I use IP address, I can login without any problems.

But yeah, most of the times just rebooting the server fix this issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.