Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Our LDAP server recently crashed and now we are facing problems reaching some of our servers.

We have a Xen guest for which the login does no longer work. In the logs, the following error appears.

FAILED LOGIN (1) on '/dev/hvc0' FOR 'root'

Here's a list of what I already tried (and did not resolve the problem).

  • Resetting the root password (mounting to host, chroot and passwd, usual stuff...)
  • Adding a new local account with root privileges (edited the sudoers file)
  • Access through SSH...

All is broken. There is a MySQL server that is failing on that vm and I would really like to fix it. The vserver runs debian squeeze and hvc0 is listed in /etc/securetty.

I'm out of options... All help is appreciated!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Your PAM configuration may be wrong. Your configuration should be something like this:

auth [success=1 default=ignore] pam_unix.so
auth required pam_ldap.so use_first_pass
auth required pam_permit.so


account [success=1 default=ignore] pam_unix.so
account required pam_ldap.so
account required pam_permit.so

With those lines, local files are checked before LDAP.

share|improve this answer
    
It was indeed a PAM issue. replaced the pam.d directory with the contents of a freshly installed server et voila, I'm in! We will configure it for LDAP once the LDAP is up again. :) –  mstaessen Apr 21 '12 at 0:51

I think you face two distinct configuration options that forbids root logins. One is that root login will be allowed (by /sbin/login or PAM configuration) if there is an entry in /etc/securetty file for hvc0 device. Other is that sshd by default forbids login directly to root account.

You should add hvc0 line/item to /etc/securetty file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.