Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using godaddy CentOS, Cpanle, suphp with easyapache and when i try to hit my php page i get 500 error and following lines in Apache log:

[Fri Apr 20 04:23:48 2012] [error] [client 182.178.175.241] SoftException in Application.cpp:422: Mismatch between target UID (99) and UID (502) of file "/home/user/public_html/phpinfo.php"
[Fri Apr 20 04:23:48 2012] [error] [client 182.178.175.241] Premature end of script headers: phpinfo.php
[Fri Apr 20 04:23:48 2012] [error] [client 182.178.175.241] File does not exist: /home/user/public_html/500.shtml

I feel that issue is with permission but i font know from where this target user is coming (nobody use of uid 99) and where should i set those permissions. I tried setting phpinfo but no success. can any 1 please help me.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This sounds like an ownership problem. The error message seems to say that it requires the UID (i.e the owner) of the file to be 99 but it is currently 502. My guess is that 502 is your UID and 99 is Apache. (Actually, judging on the comments in other forums when searching for this error message, it's probably the "nobody" user.)

Try sudo chown nobody phpinfo.php

If you have some other method of changing ownership of files through cPanel, feel free to use that instead.

share|improve this answer
    
issue has been resolved by disabling suphp in apache conf. thanks all –  Kashif Apr 20 '12 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.