Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't commit .htaccess files only. When I am try to commit on terminal , I am getting this error:

svn: PUT of '/svn_sr/!svn/wrk/2ce2c337-a371-411d-ae18-c39acaa2d846/trunk/crm/.htaccess': Could not read status line: Connection reset by peer (http://www.xxx.com)

I am getting below error when I try to commit on zend-studio:

svn: Connection reset
svn: PROPFIND request failed on '/svn_sr/trunk/crm/.htaccess'

I think this is permission problem.But I don't know how can I solve. I was find a few stuff about this problem on the web but I can't understand or I can't solve problem.

My virtual host configuration:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName www.xxx.com
        DocumentRoot /home/umutftp
        <Location /svn_sr>
                DAV svn
                SVNPath /var/svn/sr
                AuthType Basic
                AuthName "Development area"
                AuthUserFile /etc/apache2/dav_svn.passwd
                Require valid-user
        </Location>

        <Directory /home/umutftp>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog ${APACHE_LOG_DIR}/xxx_error.log
        LogLevel warn
        CustomLog ${APACHE_LOG_DIR}/xxx_access.log combined
</VirtualHost>

Note: I know little English. I will be happy if you are explain in simple language.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Do you have a section that looks like this...

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>

...or anything similar, elsewhere in your configuration?

This is in Apache's default configuration pretty much no matter where you got it. It's specifically built to break access to .htaccess files; remove it to be able to work with them in SVN.

share|improve this answer
    
Yes,I have.I inactive this section but the problem not solved.Also I tried inactivate rewrite engine in .htaccess file at main directory(/home/umutftp) but this also did not work :( –  mesuutt Apr 23 '12 at 7:41
    
What does the Apache access log record when that request is attempted? –  Shane Madden Apr 23 '12 at 17:00
    
pastebin.com/wJzDHS34 –  mesuutt Apr 24 '12 at 7:05
    
I don't see the PUT request or any attempt at it in that log, just the propfind that failed in the expected way. See if you can find that request in the log? Also, try setting AllowOverride None in the <Location /svr_sr> block. –  Shane Madden Apr 24 '12 at 15:12
    
When I commit other file I see the PUT request in access log file but when I try to commit .htaccess file I don't see PUT request.Also AllowOverride rule not change anything. –  mesuutt Apr 24 '12 at 15:52
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.