Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting a "500 - Internal Server Error" from the outside, the local connection gives me the 500 error as well as long with some more debugging information. The problem seems to be with FastCgiModule:

HTTP Error 500.0 - Internal Server Error
An unknown FastCGI error occured

Module  FastCgiModule
Notification    ExecuteRequestHandler
Handler PHP_via_FastCGI
Error Code  0x80070005

I ran the command to test the connection by force running cgi:

"C:\Program Files (x86)\PHP\php-cgi.exe" <path to website>

That did output the PHP/HTML code, not the 500 error. I believe the problem has to lie with the IIS. The server was up and running fine on Friday and no changes were made that I am aware of. A restart of the server changed nothing, still displays the error.

Hope I provided this to the correct website/forum. Does anybody know why I would be getting this error?

EDIT: Added in 500 error and "Unknown FastCGI error occured"

share|improve this question

2 Answers 2

up vote 0 down vote accepted

The 500 error may be caused because the user running C:\Program Files (x86)\PHP\php-cgi.exe doesn't have proper permissions on the directory containing your PHP files.

  1. Check the service manager to see which user is running this process.
  2. Check the security ACL for the PHP directory and files.
  3. Ensure that the user in (1.) has read/execute and list directory permissions and propagate these to all files.
share|improve this answer
    
I have tried giving anonymous access to a local administrator account, and I am still unable to get the data up. I'm really unsure what it is, but I would think that would eliminate user rights problems, correct? –  Fleppar Apr 23 '12 at 13:41
    
Have you tried setting read/execute/list permissions over those areas needing read only access and read/execute/list/write over those areas needing read/write access for IUSR,IIS_USERS? –  leftcase Apr 24 '12 at 12:11
    
I did try that, thank you for your help! The problem was actually with the application pools. I think there was an issue on the domain level that was messing up user rights, so I had to adjust the application pools and change them to "LocalSystem", which eliminated the problems right away. Which would make sense that there was no changes to the server itself, but the problem occurred "out of no where." Hope this helps anybody with this problem. Thanks. –  Fleppar Apr 24 '12 at 17:06

I had an identical error message and found out the problem was a missing dll, msvcr71.dll. I found a copy of this dll under Mysql and copied it to

C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\ directory, and also, just in case to C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\etc directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.