Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been running a CentOS6 server with a local colocation company for several months. I had OpenSSL setup to allow only my keys when logging in and I had no issue until recently. I also have webmin and apache running on this system.

Last night, all of the services shut down and now my ssh keys are being rejected. However, communication to the server is still there - so I know that the network wasn't disconnected, etc.

I'm the only user who is allowed to login, and it's via private key. I'm not an expert but I had the server locked down fairly well, but when I try to login i see:

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

I'm stuck with what to do. I can't access webmin (it's not running) so I can't reboot the server. Being a weekend, and a night/early morning it's impossible to get a hold of someone at this colocation center to reboot it for me.

Do I have any choices other waiting until I can get someone to reboot it, or Monday when I can drive down there and access it locally myself? Could some sort of software crash/error be causing this private key error or should I be concerned that someone gained access to the server and removed my keys?

P.S. The last thing I saw before I closed my last connection yesterday, was when I tried to resume a screen, it said:

screen: error while loading shared libraries: libutempter.so.0: cannot open shared object file: No such file or directory

I've never seen that before. After that I disconnected and attempted to re-connect and have been getting the permission denied ever since.

share|improve this question

migrated from stackoverflow.com Apr 22 '12 at 18:26

This question came from our site for professional and enthusiast programmers.

2  
If it can't find the library, your root disk may have been corrupted. Impossible to say for sure without physical access, but you may need to prepare for getting a new hard drive. –  Joachim Isaksson Apr 22 '12 at 16:13
    
The missing library error indeed looks like a broken disk or corrupt filesystem. PS If your server has any kind of remote management hardware built in (IPMI/KVM is pretty common nowadays on server hardware), monday would be an excellent time to set it up after fixing the main problem. –  rackandboneman May 6 '12 at 19:30

1 Answer 1

Have you tried:

ssh -D 7070 -i ~/.ssh/foo.pem user@xxx.xxx.xxx.xxx

and you can use

ssh-add foo.pem

to avoid the -i ~/.ssh/foo.pem part next time.

share|improve this answer
    
I don't have a pem file but I tried ssh -D 7070 -i ~/.ssh/id_rsa.pub user@server and got the same result - permission denied. These keys were working fine until last night - even yesterday I was on this server without any issue. I'm the only one with ssh access so I can't understand what's happened. –  BotskoNet Apr 22 '12 at 15:02
    
@BotskoNet that's weird...this morning, I got the same issue on my AWS EC2, and finally solved just by adding the -i part...well, hope you'll solve this issue at the end. –  Kjuly Apr 22 '12 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.