Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had 2 large imports which screwed up. While I was trying to work out what was wrong I removed the mailboxes (sorry). I have discovered that the import requests are still there and when I try to remove them I get the following error.

corp.dcsgroup.com.au/Corp Users/Administration/Test Acct isn't a mailbox user or mail-enabled user.
    + CategoryInfo          : NotSpecified: (0:Int32) [Remove-MailboxImportRequest], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 70B4CA0,Microsoft.Exchange.Management.RecipientTasks.RemoveMailboxImportRequest

I am a bit worried I have messed somethig up permanently. Anyone have any ideas how to fix this?

share|improve this question
1  
Did you try to reconnect the mailbox to the AD user account or recreate the mailbox or restore it from the dumpster? –  MBu Apr 24 '12 at 19:11
    
I am about to reopen this problem. The second failed request never timed out. I have tried reconnecting it to a mailbox but I have to deal with "Failed to communicate with the mailbox database" message when trying to remove. –  Ablue Apr 30 '12 at 3:16
add comment

1 Answer

up vote 0 down vote accepted

Trying to reconnect the mailboxes didn't work. The shell would give me an error claiming it couldn't connect to the mailbox database. Leaving it for a few days made the mailbox information drop from the mailbox import request; it was then I was able to remove the request.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.