Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So i've been trying to edit the /etc/fstab file to add the "usrquota" however I tried editing it and it fails any commands that I should follow on this guide afterwards(http://serverfault.com/questions/37737/quotas-in-vsftpd), this system is a VPS with just one drive running CentOS

Current contents(the original)

  none    /dev/pts        devpts  rw      0       0

Mount output

[root@s1 etc]# mount
/dev/simfs on / type reiserfs (rw,usrquota,grpquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
none on /dev type tmpfs (rw)
none on /dev/pts type devpts (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

Mtab contents

/dev/simfs / reiserfs rw,usrquota,grpquota 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
none /dev tmpfs rw 0 0
none /dev/pts devpts rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0

First bit it fails upon after editing the fstab

[root@s1 ~]# quotacheck -cug /home
quotacheck: Mountpoint (or device) /home not found.
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.

Would appreciate any help

share|improve this question
    
what does mount return? What's in /etc/mtab ? –  Dmitri Chubarov Apr 24 '12 at 15:06
    
Updated :) Could you take a look? –  Saulius Antanavicius Apr 24 '12 at 16:01
    
Looks good actually. How do commands fail? Is it quotacheck that fails after creating /aquota.user and /aquota.group saying that there is no support for quotas? –  Dmitri Chubarov Apr 24 '12 at 16:32
    
Im guessing thats because I haven'tassigned user quatalimitation to that? or? –  Saulius Antanavicius Apr 24 '12 at 16:56
2  
Since you do not have a device for /home you may only set up quotas for the whole root file system (which is perfectly ok). –  Dmitri Chubarov Apr 24 '12 at 18:17
show 3 more comments

2 Answers

What file system do you want to place quotas on? The example you give is a pseudo filesystem. I doubt you can place quotas on that and it certainly would not do anything useful.

Chapter 7. Implementing Disk Quotas of the CentOS deployment guide describes in detail what is needed.

share|improve this answer
    
I've had a read of thataswell and got stuck on the exact same part when it came to editing fstab –  Saulius Antanavicius Apr 24 '12 at 15:59
add comment

VPS environment does not update your fstab so automated tools such as webmin can just be configured to look at /etc/mtab instead. Another option would probably be to add the following line to /etc/fstab

    /dev/simfs / reiserfs rw,usrquota,grpquota 0 0

Then you may follow the advice that you referred to replacing /home with /

share|improve this answer
    
This might be the key why you are unable to get this working as described in the CentOS guide. You haven't specified where your machine is hosted and what type of management access you have. I (and the author of the CentOS documentation) assumed you were working on a regular CentOS server but if the system has been configured to use webmin you will ahve to check either the documentation of the hosting company or a plain webmin guide. But as @dmitri-chubarov wrote you need to place quotas on a file system as a whole, if /home isn't a separate file system you can't limit just that directory. –  Bram Apr 25 '12 at 6:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.