Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm solving problem with slow DHCP request/respons about 45 secs...toplogy is [L2] DELL 6248 -> [L2->L3] router (cisco) -> firewall Debian server with DHCP -> gateway to internet I think that problem is on DELL 6248 where clients are connected. When client connect to 6248, his MAC address is not in bridge CAM table until he don't get IP address from DHCP (IP form same network that has L2 dell switch has configured) So I need to configure DELL switch to accept clients on port from different networks (I mean standard windows 192.168...) Somebody can help me with this configuration?

share|improve this question
2  
So you're saying you're expecting the MAC table to have an entry for a node from a different broadcast domain? –  Shane Madden Apr 25 '12 at 0:58

1 Answer 1

Do you have Portfast set up on the interfaces?

  • Portfast Allows immediate transition to a forwarding state
  • Port still participates in STPUsed for non-switch devices
    • Clients
    • Servers
    • Printers
  • Prevents unnecessary timeouts from DHCP servers
  • Portfast configuration ignored when port is connected to another switch

When a host is attached to a network switch such as a computer, printer or server, STP will run on the port. Forwarding state will occur, albeit after a delay of about 50 seconds while it goes through the listening and learning states.

As STP is running, no user data will pass via the port. The host NIC is active however it has no network connectivity. Some user applications can time out during the period, such as DHCP. This would cause the host to self issue an Apipa address (169.254.x.x) this address will not allow the host to communicate on the network.

In order to allow immediate transition of the port into the forwarding state for Hosts, enable the STP PortFast feature. PortFast immediately transitions the port into STP forwarding mode upon linkup with less than a 5 sec delay. The port still participates in STP. So if the port receives a BPDU from another Network bridge (switch), the port ignores PortFast and processes the BPDU as normal. The port transitions through Listening, learning, forwarding or blocking state with the original 50 sec delay. There is no danger of causing a data Loop as STP is always listening for BPDU’s with or without PortFast enabled on all ports.

It is highly recommend to enable PortFast on all client ports. It is highly discouraged to Disable STP under any circumstances unless there is a specific reason to. Without STP the switch will behave as an unmanaged switch!

To configure Portfast on an interface:

console# config
console(config)# interface ethernet g5

This command will vary on different vendor platforms

This enables Portfast on this port:

console(config-if)# spanning-tree portfast
console(config-if)# exit
share|improve this answer
    
Thanks for quick respond, perfect solution and problem explanation. It speed up dhcp communication to 1-3 seconds. –  tombo Apr 25 '12 at 1:10
2  
Caution: Do not enable portfast on any port that might get connected to anything other than an end station. (Unless you know exactly what you're doing.) –  David Schwartz Apr 25 '12 at 2:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.