Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In our environment we have several printers with the scan to folder functionality set up. It worked pretty well. Long story short- I needed to reboot our file server one evening (the server whose $hares where all the scans go), upon on boot up I received a message stating the name of the file server (i.e AcmeFS1; Windows Server 2003) could not be used because there was a duplicate name on the network. I found that somehow another printer on the network was using the name of the file server. Weird - I know. People could no longer scan to their folders. I ran an nbtstat on the file server and found that the local netbios name table was empty. I renamed the offending printer and rebooted the file server once more. This time, no error, and once I ran nbtstat again, I found that correct name and domain in the local netbios name table. Problem is, scan to folder is still not working. I know this was working before I rebooted the file server the first time. Anyone have any idea what is going on and how to fix?

Thanks.

FIXED: Not sure why the reboot didnt fix it but I restarted the "Server" service on the file server and the problem went away.

share|improve this question
3  
Configure DNS, everywhere, and be done with it. Don't rely on netbios name resolution. –  SpacemanSpiff Apr 25 '12 at 14:07
    
I have a dns server and all my printers and servers point to it. –  tking Apr 25 '12 at 15:11
    
Note that the "Server" service includes the built-in SMB service for Windows. –  tking Apr 25 '12 at 16:47
add comment

2 Answers 2

I can guess what happened. You have the IP address of your server in the range assignable by your DHCP server to the printer. This is a bad idea if I'm right. Workstations, embedded devices, and servers should each have their own scopes/subnets. You can still use DHCP to assign IP addresses, but you should use a reservation for each printer. I would recommend static IPs for servers.

What probably happened is that when you rebooted the server, the DHCP server assigned the IP used at least at some point in the past to the printer. The printer looked in DNS to see what DNS name was assigned to that IP. This was the name of your file server, because the IP was used at some point in the past by your file server.

This happens because while the Windows world implements Dynamic-DNS updating (where the computer determine which name it has in DNS at boot time and registers it with the DNS server), much of the Unix/embedded world will let the DNS server assign a name upon boot if a name is already registered to its IP address.

share|improve this answer
    
Actually I don't. The IP did not get re-assigned. Somehow the name of the printer got renamed to the fileservers name- I had to go into the web interface of the printer to change it. I'm assuming someone was messing with the settings on the printer itself, not knowing what they were doing. I have static IP's for my servers and printers. I learned that lesson the hard way once when I was doing consulting work, I plugged my laptop in at one of my new clients and it took the IP address of the DHCP server!!! The previous admin was clearly incompetent. –  tking Apr 25 '12 at 16:47
add comment

Restarting the "Server" service on the file server and the problem went away. The server service is what handles inbound SMB requests.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.