Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When trying to save a new document directly from the Office 2010 program to a SharePoint 2010 document library the users are prompted to input credentials.

So far by adding ntlm-auth settings to Firefox and automatic logon for IE9 the users are not prompted to give their domain logon when trying to open the files.

How do I carry these settings over to apply to saving a new document as well?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

If your SharePoint site is an FQDN rather than a single name, you might want to try this registry modification and see if it helps. There is no download, the functionality is included in Windows 7, you simply need to create the registry value.

  1. Click Start, type regedit in the Start Search box, and then press ENTER.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. On the Edit menu, point to New, and then click Multi-String Value.
  4. Type AuthForwardServerList, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type the URL of the server that hosts the Web share, and then click OK.
  7. Exit Registry Editor.
  8. Restart the WebClient service.
share|improve this answer
    
This method worked fine, it took several variations of the URL before it worked by entering in the format of 'http:// intranet.domain.com'. I wonder if there is a non-registry editing method to this but for now it is acceptable. Thanks. –  CokaKola99 Apr 25 '12 at 20:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.