Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Title explains it...

If I join machines to "phoenix.domain.com", the windows 7 login screen displays "PHOENIX" under the login prompt when it is rebooted.

If I simply type a username into the prompt, as well as a password, it returns "invalid username or password".

If I type phoenix.domain.com\User.Name, and the password, it works fine. Once I'm logged in, any priv-escalation requests display domain: PHOENIX, and allow me to log in as would be ex

share|improve this question
    
Can you login as PHOENIX\username without the FQDN? Which version of Windows 7? –  TheCleaner Apr 25 '12 at 18:30
    
I can't. Once I get logged in, however I can auth against it as you would expect. With privs escalation requests, I can log in with PHOENIX\User.Name –  Ryan McDermott Apr 25 '12 at 18:52
1  
    
^ +1 AND LMAO!! I was going to direct him through the same things? Is NetBIOS disabled on this client? Do you have a third-party firewall? –  JohnThePro Apr 25 '12 at 20:16

3 Answers 3

The shortened version if called the NetBIOS name of the domain, and is there mostly for backwards compatibility. You should, however, be able to login using either the shortname (NetBIOS name) or the FQDN (fully qualified domain name).

If you have issues logging in with one or the other, I would check DNS settings on the workstation first (they should be pointed to the domain controller), and then start to delve into firewall issues.

share|improve this answer
    
I figured it could be a DNS setting, so I removed the secondary DNS, leaving only the DC... Still no dice :(. Netbios-based authentication works after login, for instance when authing to the DC over RDP, or for privilege escalation requests from windows. –  Ryan McDermott Apr 25 '12 at 18:28
    
What about firewall? Do you have only the built-in Windows firewalls running? –  JohnThePro Apr 25 '12 at 20:53
1  
"I removed the secondary DNS, leaving only the DC"... so you had another DNS server there which is not an AD DNS? Bad, bad, bad. A domain-joined computer should use only domain DNS servers. –  Massimo Apr 25 '12 at 21:27

I personally don't like the Windows 7/Windows Server 2008/R2 logon screen as I don't think it's very intuitive for determining what domain you're logging on to (local or AD). I always preface the username with the NetBIOS name of the domain if I want to log on to the domain. If you leave the domain out I believe it defaults to logging on to the local machine. Try the following:

NetBIOSDomainName\Username

FQDN\Username

Username@domain.tld (where domain.tld is the AD domain name/DNS namespace).

share|improve this answer

Sounds like your PC is not resolving the domain properly. Make sure the DNS suffix list associated with the PC network card has "phoenix.domain.com" (and possibly "domain.com") included, and your domain login should work correctly.

(IP Settings -> Advanced button -> DNS tab)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.