Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am booting without IOS and I get this prompt:


then I issue these commands:

ap: set IP_ADDR
ap: set NETMASK
ap: tftp_init
ap: ether_init

Then I want to copy an IOS image to flash:

copy tftp:// flash:

But I get error:

tftp:// no such file or directory

But I have double checked everything, the tftp server is running, the IOS is in the tftp, the IOS image name is correct, and IPs are fine, and router is plugged in the switch, etc.

How can I troubleshoot this issue please ? I really need to recover an IOS image into that AP.

share|improve this question
up vote 1 down vote accepted

You should make sure that your TFTP server is actually functioning correctly. Try testing from a non-AP source. I suspect that you will find that it is not AP specific, but rather a problem with the TFTP server.

Assuming you're running tftpd, you should check the logs, which are usually located in/var/log/messages. You can start the TFTP daemon with -vvvvv for highest verbosity.

share|improve this answer
But also how can I check if the connection is actually working on the AP ? I dont have the "ping" command on the AP recovery mode. – Jonathan Rioux Apr 25 '12 at 22:08
@JonathanRioux One step at a time. The first step is to verify that the tftp server works. After that, you can ping the AP from another device on the same network. It should respond. – MDMarra Apr 25 '12 at 22:37
It was my TFTP server that did not worked. Now it works, thanks! – Jonathan Rioux Apr 26 '12 at 17:30

this error occurs when you do not set the path of the file on the tftp server correctly. for eg. on tftpd32 you should set the location of the current directory of the specific server interface where the file is located!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.