Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would appreciate it so much if someone could guide me through setting up a small domain with windows 2003.

My regular lan uses a router to issue ip addresses to a few pcs. The router's ip address is 192.168.2.1, and the router issues ip addresses like 192.168.2.5 to the various pcs.

I would like to set up a win2k3 domain for testing. I'd like it to do the regular first server tasks like act as a dhcp server, and set up AD. When I start the new role wizard I choose the option which is supposed to wizard me through a set of options that will result in a standard 'first' server. However I can't get it to succeed, and I'm guessing that the #1 reason is that I am not setting up the network ip addresses correctly.

My objective is to have my regular workgroup based LAN work just as usual, and to have a completely separate domain with the new win2k3 server and a couple of other test pcs. They both need to use the same router for internet access (at least that is how I think it should work). All of the pcs and the router are connected by a switch.

Here are the settings I use to fail

windows 2003 server ip addresses tcpip address static 192.168.3.1 (that's supposed to be the new domain's root address) subnet mask 255.255.255.0 default gateway 192.168.2.1 (that's the router address) preferred dsn server 192.168.2.1

When I try to save that, it says the default gateway is not on the same network segment (subnet) is as defined by the ip address and subnet mask.

What settings should I use? Since the new server is just for testing I can't rely on it to be on all the time, and thus need my regular lan to continue to use the router for ip addresses.


I did set up a second router just like gravyface suggested and in general it's gone well. The domain controller is set up as 192.168.3.10; the router is 192.168.3.1.

One issue tho is that it is not handing out ip addresses. I initially forgot to turn off dhcp services on the router. But then I did, and I activated dhcp services on the new server. I created a range 192.168.100-199 for it to assign. I've hooked up a windows xp machine and done ipconfi /release and /renew and it comes up with 0.0.0.0. I can't see why. I am hoping that someone can guess why dhcp services are not working right?

share|improve this question

4 Answers 4

The gateway needs to be on the same subnet.

Why not just grab a cheap Linksys or D-Link router, plug it's Internet port (or WAN port) into your real office network switch and setup your test network behind this new network?

By default, your typical home router will be set to use DHCP or "Automatic" on the WAN/Internet interface, so your real router will give it an IP.

You can then disable DHCP on the test router's LAN, change the test router's LAN IP address to 192.168.3.1 and then set that as your 2K3 server's default gateway.

Works fine. And Internet will work fine for all your test workstations on the 192.168.3.0/24 subnet as well as your test server.

share|improve this answer
    
Oh, interesting. I have an older linksys router that I could try this with. I think I understand what you're suggesting, and after I give it a try I'll post the results here. Thanks! –  meridian Apr 26 '12 at 1:11
    
I did set up a second router just like gravyface suggested and in general it's gone well. The domain controller is set up as 192.168.3.10; the router is 192.168.3.1. One issue tho is that it is not handing out ip addresses. I initially forgot to turn off dhcp services on the router. But then I did, and I activated dhcp services on the new server. I created a range 192.168.100-199 for it to assign. I've hooked up a windows xp machine and done ipconfi /release and /renew and it comes up with 0.0.0.0. I can't see why. I am hoping that someone can guess why dhcp services are not working right? –  meridian Apr 27 '12 at 2:36
    
Create a new question for your DHCP issues and you'll get more responses. –  gravyface Apr 27 '12 at 17:42
    
I resolved this by reinstalling windows 2003 from scratch and then running the first server wizard again. Without the other live dhcp server in the mix (originally I'd forgotten to turn off dhcp services on the 2nd router) the wizard worked well. I would love to see a dump of what it does...else I don't learn so much. Gravyface thanks for your help with this. –  meridian Apr 30 '12 at 17:46

For this to work you'll need to have two NICs on the Windows 2003 server and have Routing and remote access enabled.

It'll be much easier to simply use static IPs for your two test machines.

Configure the server as 192.168.2.200 with a default gateway of 192.168.2.1. Setup the workstations as 192.168.2.201 and 192.168.2.202. On the server and the domain workstations setup 192.168.2.200 as the ONLY DNS server.

share|improve this answer
    
Thanks mrdenny. I will try this if the suggestion of gravyface does not work for whatever reason. I think the server's mobo has two nics built in so that helps. –  meridian Apr 26 '12 at 1:13

This may fix your network access problem from the test network

You can manually add a route to your test server-

Set your default gateway to your test server address of 192.168.3.1 Now add a route to your test server-

open up CMD prompt and try the command below (NOTE the -p will make it a persistent route so when you reboot the server the setting remains) You may want to test the setting first before making it persistent (you can always delete it later anyway)

Route add –p 192.168.3.0 MASK 255.255.255.0 192.168.2.1

This will now forward data from your 192.168.3.0 network to your 192.168.2.0 network via the server with the persistent route.

:: To display the list of routes type the command below
Route Print
share|improve this answer

This is being pedantic, but clarification is needed as your initial understanding of ip addresses and subnet masks fitting together was broken.

In your question you mention the range "192.168.100-199" in two places. With a subnet mask of /24 you need to be clear of your third octet as well.

Is your range 192.168.3.100-199 or is it 192.168.100.0-192.168.199.255 with the latter being representative of a subnet mask of /16? I am not sure if the latter will be dished out by your DHCP server, but it will not work well with your router that is sitting on 192.168.3.0/24.

share|improve this answer
    
Eh, sorry. 192.168.3.100-199 is the range. Thanks for noticing. –  meridian May 5 '12 at 1:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.