Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Suse Linux 12.1 and i am trying to mount a single RAID 1 disk, to explore the files in it. However when mounting it:

 # mount /dev/sdc1 /mnt/test
  mount: unknown filesystem type 'linux_raid_member' 

I started reading around and many advised to just force the filessystem type

  # mount -t ext4 /dev/sdc1 /mnt/test
  mount: /dev/sdc1 already mounted or /mnt/test busy

when trying

 umount /dev/sdc1                 
 umount: /dev/sdc1: not mounted

Could someone provide some advise?

I am running my machines insed an ESXI server and it is a virtual disk. However this should not play, as this disks are not used by any other machines

thaknks!

share|improve this question
    
can you please post the output of fdisk -l ? – Feiticeir0 Apr 26 '12 at 10:52
up vote 36 down vote accepted

You should not mount it directly using mount. You need first to run mdadm to assemble the raid array. A command like this should do it:

$ mdadm --assemble --run /dev/md0 /dev/sdc1

If it refuses to run the array because it will be degraded, then you can use --force option. This is assuming you don't have /dev/md0 device. Otherwise, you need to change this name.

When this command is executed successfully, you can mount the created device normally using:

$ mount /dev/md0 /mnt/test
share|improve this answer
    
Seems good! I'll check it out asap! – user1092608 Apr 26 '12 at 15:19
    
Your answer is very useful! Thank you! – user190255 Sep 17 '13 at 7:23
    
In my case it does not work when I take 1 HDD only. Before is RAID 1 for 2 HDD – tquang Jan 20 '15 at 1:36
1  
@quimnuss: You can use mdadm --stop /dev/mdx – Khaled Jun 13 '15 at 7:11
1  
If anyone still gets the mdadm: /dev/sdb1 is busy - skipping message you can stop the device on with mdadm --stop /dev/mdx or check the /proc/mdstat to check if the device was automatically mount by your system. – altmas5 Nov 27 '15 at 16:29

protected by Tom O'Connor Sep 17 '13 at 7:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.