Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I need to deploy a package that creates a service on the client's machine. I published it in AD so that it is available however, when the client attempts to install, there is a permission error in creating the service.

How do I enable end users to perform the installation from the control panel?

Thanks

share|improve this question
    
msiexec /i \\server\sdp\software.msi is failing with the same error. The installation gets about half way then chokes on creating the service. –  bob Apr 26 '12 at 16:57
2  
If a manual msiexec is also failing, it's probably time to contact the vendor and ask them to fix their MSI. –  jscott Apr 26 '12 at 17:48
    
Which version of Windows is the client running? You may run into more security issues with Windows 7 and UAC, depending on your environment's security policies. –  SturdyErde Apr 27 '12 at 0:41
    
Thanks, I tried testing with XP and Win7 (uac on and off) but to no avail. If I copy the msi to the desktop, the install runs ok. –  bob Apr 27 '12 at 18:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.