Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

if have recently installed OpenSuse 11.1 from a dvd and then, following this advice , upgraded to 11.2, 11.3, 11.4 and finally 12.1 (no comment on this one, please...). Now the problem is that my wlan0 is not coming up... i have it configured via yast to not use netmanager and a static ip4 adresse. I have found the file /etc/sysconfig/network/ifcfg-wlan0 (link to gist.github). which looks good to me. If the system is just powered on and i then set

ifconfig wlan0 $myip up
route add default gw $mygw

for wlan0 and a default route. The interface works.
I really would like to get advice how i can solve this. I have looked to the output of dmesg

dmesg | grep wlan0

and that told me

[   31.065187] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   34.212555] wlan0: authenticate with 00:22:b0:99:a6:63 (try 1)
[   34.215568] wlan0: authenticated
[   34.220333] wlan0: waiting for beacon from 00:22:b0:99:a6:63
[   34.270308] wlan0: beacon received
[   34.274061] wlan0: associate with 00:22:b0:99:a6:63 (try 1)
[   34.277096] wlan0: RX AssocResp from 00:22:b0:99:a6:63 (capab=0x431 status=0 aid=2)
[   34.277099] wlan0: associated
[   34.285948] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

However i cannot interpret this...

Sincerely

Matthias

share|improve this question
    
After you run the up command, what does ipconfig wlan0 show? –  Tim Apr 26 '12 at 20:10
    
did you say "ipconfig"? Is that a typo? Did you mean ifconfig? –  Matthias Apr 26 '12 at 20:12
    
Yes, that would be a typo. –  Tim Apr 26 '12 at 20:25
    
I appended to the gist i mentioned: gist.github.com/2502315 –  Matthias Apr 26 '12 at 20:33
    
That output is showing an up status. –  Tim Apr 27 '12 at 19:01

1 Answer 1

up vote 1 down vote accepted
+50

How about adding ONBOOT=yes to your ifcfg file? That's what I do in RHEL/Centos land.

Alternately, this SuSE site says that STARTMODE=onboot might be what you want.

share|improve this answer
    
Thanks for the answer and the article. Well worth reading (especially because opensuse.de's search-function does not return anything when asked for "startmode"). –  Matthias May 10 '12 at 8:20
    
Happy to help! The google terms I used were "opensuse interface configuration file". –  Bill Weiss May 10 '12 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.