Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

got a problem here. In my development server, I ran into a problem when I try to search using django/haystack with the whoosh backend engine.

The path to your Whoosh index '/home/foo/bar/whoosh/index' is not writable for the current user/group.

Hmm this seems like a obvious permissions problem, but when I check my folder

drwxrwxr-x 2 foodball django 4096 Apr 27 03:17 index

it seems correct, as the user apache is added to the group django. May I know what seems to be the problem, is apache not the user the process is running under?

share|improve this question
    
What are the permissions on /home/foo/bar/whoosh ? –  symcbean Apr 27 '12 at 12:43
    
drwxrwxrwx 3 foodball django 4096 Apr 27 03:17 whoosh/ –  amateur Apr 27 '12 at 12:45
    
I'm facing the same issue. Was that resolved? if yes, what was the soluton? –  Ankit Jaiswal May 18 at 17:14

1 Answer 1

If SELinux is enabled, it might cause the error. If you don't need SELinux or just quickly want to test if it's the reason, try command setenforce 0 and see if that helped. SELinux can be permanently disabled by setting it to disabled in /etc/selinux/config.

share|improve this answer
    
couldn't find the command nor the file /etc/selinux/config. –  amateur Apr 27 '12 at 11:56
    
do i have to create one myself?? –  amateur Apr 27 '12 at 11:56
    
Then you either are not using the server as root or you don't have SELinux installed at all. –  Janne Pikkarainen Apr 27 '12 at 12:08
    
hmmm o+w is fine though... –  amateur Apr 27 '12 at 12:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.