Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The script I'm using requires your files to be chmoded to 666 for editing, although even after I've chmoded the files it's telling me it couldn't write the files.

I think it might be a security issue or something since I also get:

script.cgi: ERROR Can't connect to host.com:80 (Permission denied) LWP::Protocol::http::Socket: connect: Permission denied at /usr/local/share/perl5/LWP/Protocol/http.pm line 51.

If anyone could help me out I would really appreciate it. :)

share|improve this question
4  
The script is crap. Get one written by someone who knows something (anything!) about file permissions. –  womble Apr 27 '12 at 17:03
1  
Truly, if you don't know what the script does and why it does it, you shouldn't be running it at all. –  Magellan Apr 27 '12 at 18:05

2 Answers 2

up vote 1 down vote accepted
  • check parent directory that it has write permission as well
  • make sure that /usr/local/share/perl5/LWP/Protocol/http.pm has right permission (accessible by whoever trying to run this script)
share|improve this answer

Is this script running via a web interface? If so, is selinux enabled? You can check that by running getenforce.

If selinux is enabled, you can either enable it to access out by tweaking the proper bool for that ( http://wiki.centos.org/TipsAndTricks/SelinuxBooleans ), or disable selinux in /etc/sysconfig/selinux

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.