Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed Jenkins on my debian server. It is set on port 8080 and when I try connecting to it nothing happens. I know it is running because when I do:

root@jini01:/etc/default# /etc/init.d/jenkins restart

I get this back.

[ ok ] Restarting Jenkins Continuous Integration Server: jenkins.

Here is my jenkins config file:

# defaults for jenkins continuous integration server

# pulled in from the init script; makes things easier.
NAME=jenkins

# location of java
JAVA=/usr/bin/java

# arguments to pass to java
#JAVA_ARGS="-Xmx256m"
#JAVA_ARGS="-Djava.net.preferIPv4Stack=true" # make jenkins listen on IPv4 address

PIDFILE=/var/run/jenkins/jenkins.pid

# user id to be invoked as (otherwise will run as root; not wise!)
JENKINS_USER=jenkins

# location of the jenkins war file
JENKINS_WAR=/usr/share/jenkins/jenkins.war

# jenkins home location
JENKINS_HOME=/var/lib/jenkins

# set this to false if you don't want Hudson to run by itself
# in this set up, you are expected to provide a servlet container
# to host jenkins.
RUN_STANDALONE=true

# log location.  this may be a syslog facility.priority
JENKINS_LOG=/var/log/jenkins/$NAME.log
#HUDSON_LOG=daemon.info

# OS LIMITS SETUP
#   comment this out to observe /etc/security/limits.conf
#   this is on by default because http://github.com/jenkinsci/jenkins/commit/2fb288474e980d0e7ff9c4a3b768874835$
#   reported that Ubuntu's PAM configuration doesn't include pam_limits.so, and as a result the # of file
#   descriptors are forced to 1024 regardless of /etc/security/limits.conf
MAXOPENFILES=8192

# port for HTTP connector (default 8080; disable with -1)
HTTP_PORT=8080

# port for AJP connector (disabled by default)
AJP_PORT=-1

# servlet context, important if you want to use apache proxying
PREFIX=/jenkins

# arguments to pass to jenkins.
# --javahome=$JAVA_HOME
# --httpPort=$HTTP_PORT (default 8080; disable with -1)
# --httpsPort=$HTTP_PORT
# --ajp13Port=$AJP_PORT
# --argumentsRealm.passwd.$ADMIN_USER=[password]
# --argumentsRealm.passwd.$ADMIN_USER=[password]
# --argumentsRealm.$ADMIN_USER=admin
# --webroot=~/.jenkins/war
# --prefix=$PREFIX

When I do :

ps aux | grep -i java

I get:

root     12912  0.0  0.0   7676   892 pts/0    S+   19:04   0:00 grep -i java

Why will it not show up on a browser even when i specify the 8080 port?

share|improve this question
    
Blocked by firewall? What is the output of # iptables --list Are you coming in from localhost, or outside? –  Kaz Apr 29 '12 at 19:19
    
libkmod: ERROR ../libkmod/libkmod-index.c:816 index_mm_open: magic check fail: b007fa57 instead of b007f457 iptables v1.4.13: can't initialize iptables table `filter': Table does not exist (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded. –  jini Apr 29 '12 at 19:29
    
I am coming from outside –  jini Apr 29 '12 at 19:29
    
do you have anything else running on that box? Maybe published through apache? –  MaddHacker May 14 '12 at 18:14

1 Answer 1

Try:

$ /sbin/sysctl net.ipv6.bindv6only

If this value is 1 you need to disable the setting:

$ sudo /sbin/sysctl net.ipv6.bindv6only=0

For a persistent fix: check /etc/sysctl.conf and /etc/sysctl.d/* for this setting and restart after changing it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.