Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I typed the following on my Debian system:

iptables --list

And got the following:

libkmod: ERROR ../libkmod/libkmod-index.c:816 index_mm_open: magic check fail: b007fa57 instead of b007f457
iptables v1.4.13: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

Any tips on how to fix it?

share|improve this question

3 Answers 3

You are running it as a regular user, run the command as root.

share|improve this answer
    
iptables v1.4.12.2: can't initialize iptables table `filter': Permission denied (you must be root) –  poige Apr 29 '12 at 20:18
    
yea so run it as root... –  Lucas Kauffman Apr 29 '12 at 20:26
    
Where have you noticed text like "Permission denied (you must be root) " in the message of the OP? (Rhetoric q-n) –  poige Apr 29 '12 at 20:30
1  
It's called "being an experienced sysadmin." –  Joel E Salas Apr 29 '12 at 20:31
    
I didn't, I ran the command as a regular user on one of my own machines and got the same output. –  Lucas Kauffman Apr 29 '12 at 20:31

@poige is right, your loading the wrong kernel module version. I added as a seperate answer since there wasnt really enough room in comments.

In libkmod/libkmod-index.h

/* Integers are stored as 32 bit unsigned in "network" order, i.e. MSB first.
   All files start with a magic number.

   Magic spells "BOOTFAST". Second one used on newer versioned binary files.
 */
/* #define INDEX_MAGIC_OLD 0xB007FA57 */
#define INDEX_MAGIC 0xB007F457
share|improve this answer
    
This is a far better example of how answers should be posted. Meaningful information provided so that future readers can compare their installation to the reported problem and suggested resolution. –  Magellan Apr 29 '12 at 22:36

Have you tried rebooting? Seems like module version is newer than running kernel expects.

share|improve this answer
    
Sounds like a guess to me. Some troubleshooting suggestions to verify whether or not this is the case would be more beneficial to future readers of this question. –  Magellan Apr 29 '12 at 20:39
    
@Adrian, what guess — blind or not? I'm just curios. –  poige Apr 29 '12 at 20:46
1  
Rebooting is not a solution. It may (or may not) address a particular symptom of an underlying problem, but it certainly does nothing to prevent future occurrences by the OP or anyone else who happens across this post on a search engine. –  Magellan Apr 29 '12 at 22:34
    
@Adrian, let the OP decide. Have better ideas — fill it into the form below. –  poige Apr 30 '12 at 2:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.