Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on SLES10 and am trying to extend the size of /usr I did:

lvextend -L +5G /dev/vg00/vol03

which seemed to work. Now when I try to do:

resize2fs /dev/vg00/vol03 11G

I get:

an ... is mounted; can't resize a mounted filesystem

I also tried:

ext2online /dev/vg00/vol03 11G

which results in:

warning - device size 157...., specified 288.... error invalid argument: seeking to 11811155968

The host is an VMWARE SLES9 so I can't boot from CD and therefore can not unmount /usr

Please Help.

share|improve this question
Please spend a few more seconds formatting your question. The easier you make it for people to read and understand the question, the more likely it will be answered quickly. – MikeyB Jul 9 '09 at 17:46

Don't specify the size of the new partition when you run ext2online, just let it run and auto-detect.

You've probably specified a size that's slightly larger than the actual LV.

share|improve this answer

Grab a linux boot CD like the Gparted live CD iso or the ubuntu desktop distro iso and resize your volume from there. You can mount the iso in the virtual cd-rom drive for your virtual machine.

share|improve this answer

What happens with:

ext2online /dev/vg00/vol03
share|improve this answer
I am such a noob - I followed this thread last post - and now I got lost 5 GB somewhere. I Resized /home from 10GB to 5GB and now I can not increase my /usr where could the 5 GB be??? – macbert Jul 9 '09 at 18:18
tried again to reduce size of tmp now - did run ext2online /dev/vg00/vol04 now and again i get the same error as above: error : Ivalid argument: seeking to 6222... – macbert Jul 9 '09 at 19:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.