Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just tried upgrading our Ubuntu EC2 server to 12.04 from 11.10, and it halts on several package upgrades, starting with memtest86+. CTRL+C is the only way out, and in the end there is the following error:

Errors were encountered while processing:
 memtest86+
 ubuntu-standard
 grub-legacy-ec2
 grub-pc
 friendly-recovery
 linux-image-3.2.0-24-virtual
 python-apport
 linux-image-virtual
 linux-virtual
 apport

Any advice on what went wrong and how to fix it?

UPDATE: Turns out to be a problem with GRUB, though I still don't understand what is going wrong. Why is GRUB used with EC2 at all?

share|improve this question
    
Can you provide more details about the error message? –  dwurf May 1 '12 at 8:30
    
there is no other error message, it just freezes at "Setting up memtest86+ (4.20-1.1ubuntu1) ..." –  yuttadhammo May 1 '12 at 11:14
    
What release are you starting with? What AMI id are you using as a base? –  Eric Hammond May 2 '12 at 3:01
    
11.10 to 12.04 LTS worked for me, via SSH connection. –  Plutext Jun 5 '12 at 5:37

1 Answer 1

Try the upgrade again, but this time open a second ssh session to the server, and monitor some metrics:

  • vmstat 5 will alert you to memory problems
  • iostat 5 will show you if there is any I/O happening
  • top will show you any problems with CPU spikes or load average
  • using the sysstat package, you can log many of these metrics and view them later

Find out if anything is happening. View the list of running processes in top or ps auxfw for clues. Check active network connections with netstat -utnp. Once you have this info post back anything unusual or anything you don't understand.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.