Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install couchdb, but failed installing from source.

I see in the wiki, it says if I "enable the EPEL repository", that I can just use yum install couchdb to install.

But I'm new to linux, what does "Enable the EPEL repository" mean? My linux is Fedora 16 Centos 6.2.

share|improve this question
1  
couchdb should be generally available in Fedora 16. You should be able to just run "yum install couchdb". The instructions you're looking at are for RHEL/CentOS, which are not the same as Fedora. –  cjc May 1 '12 at 8:57
    
Sorry, I just found my linux is centos 6.2 -_- –  Freewind May 1 '12 at 12:18

2 Answers 2

up vote 2 down vote accepted

You can install this rpm

rpm -ivh http://mirror.cogentco.com/pub/linux/epel/6/i386/epel-release-6-7.noarch.rpm
yum update
yum install couchdb

** epel-release on mirror has changed to 6-7

share|improve this answer

EPEL, or Extra Packages for Enterprise Linux, is a yum repository designed to offer some packages from Fedora and other places to Red Hat Enterprise Linux, and therefore also to CentOS. It's not suitable for use on a Fedora system, sorry.

To follow up on cjc's comment, above, he's right. I'm running F16 on my desktop, and yum install seems to find everything it needs right there in the Fedora repository:

[root@risby ez-pine-gpg]# cat /etc/redhat-release 
Fedora release 16 (Verne)
[root@risby ez-pine-gpg]# yum install couchdb
Loaded plugins: refresh-packagekit
Resolving Dependencies
[...many lines removed...]
Dependencies Resolved

==================================================================================================================================================================================
 Package                                            Arch                               Version                                         Repository                            Size
==================================================================================================================================================================================
Installing:
 couchdb                                            i686                               1.0.3-2.fc16                                    fedora                               533 k
Installing for dependencies:
 erlang-compiler                                    i686                               R14B-04.1.fc16                                  fedora                               984 k
 erlang-crypto                                      i686                               R14B-04.1.fc16                                  fedora                                51 k
 erlang-erts                                        i686                               R14B-04.1.fc16                                  fedora                               1.4 M
 erlang-et                                          i686                               R14B-04.1.fc16                                  fedora                               198 k
 erlang-eunit                                       i686                               R14B-04.1.fc16                                  fedora                               139 k
 erlang-gs                                          i686                               R14B-04.1.fc16                                  fedora                               606 k
 erlang-hipe                                        i686                               R14B-04.1.fc16                                  fedora                               1.0 M
 erlang-ibrowse                                     i686                               2.2.0-4.fc16                                    fedora                                96 k
 erlang-inets                                       i686                               R14B-04.1.fc16                                  fedora                               755 k
 erlang-kernel                                      i686                               R14B-04.1.fc16                                  fedora                               1.0 M
 erlang-mnesia                                      i686                               R14B-04.1.fc16                                  fedora                               663 k
 erlang-mochiweb                                    i686                               1.4.1-5.fc16                                    fedora                               338 k
 erlang-oauth                                       i686                               1.0.1-2.fc15                                    fedora                                27 k
 erlang-observer                                    i686                               R14B-04.1.fc16                                  fedora                               206 k
 erlang-public_key                                  i686                               R14B-04.1.fc16                                  fedora                               396 k
 erlang-runtime_tools                               i686                               R14B-04.1.fc16                                  fedora                               211 k
 erlang-sasl                                        i686                               R14B-04.1.fc16                                  fedora                               268 k
 erlang-ssl                                         i686                               R14B-04.1.fc16                                  fedora                               379 k
 erlang-stdlib                                      i686                               R14B-04.1.fc16                                  fedora                               2.2 M
 erlang-syntax_tools                                i686                               R14B-04.1.fc16                                  fedora                               324 k
 erlang-tools                                       i686                               R14B-04.1.fc16                                  fedora                               536 k
 erlang-webtool                                     i686                               R14B-04.1.fc16                                  fedora                                45 k
 erlang-wx                                          i686                               R14B-04.1.fc16                                  fedora                               2.5 M
 erlang-xmerl                                       i686                               R14B-04.1.fc16                                  fedora                               940 k

Transaction Summary
==================================================================================================================================================================================
Install  1 Package (+24 Dependent packages)
share|improve this answer
    
You both right, my linux is actually centos 6.2, not Fedora ... –  Freewind May 1 '12 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.