Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to convert several VMware images towards Virtualbox images. I have succesfully been able to convert my Windows Server 2003 image, but I haven't been able to convert any Windows Server 2008 image.

I found 2 solutions on the internet.

One solution involves creating a new image giving the previous .vmdk as hard disk. When I try to startup the image, I get a blue screen during booting. (I also tried to delete VMware tools before importing the image, which didn't work).

The other solution involved exporting the image to an OVF image and then open it with Virtualbox. This image got stuck in the "windows is loading" screen.

Host OS: Windows 7 Enterprise Guest OS: Windows Server 2008

share|improve this question
What OS would you be runnign the conversion on? – t1nt1n May 1 '12 at 17:01
Windows 7 Enterprise – Bart Burg May 2 '12 at 7:27
up vote 3 down vote accepted

Stick with the first solution.

The HDD types need to match. If you were using SCSI on VMware you need to be using SCSI in VirtualBox. In rare occasions you actually need to experiment a bit with disk types (ie a SCSI VMware disk will work properly only on SATA controler in VirtualBox, go figure).

Another thing that causes instability and bootup problems are IO APIC and PAE/Nx settings under System. Experiment with those. It can take couple of boots till you get it right but so far I've never had a physical (or virtual) machine I couldn't get onto VirtualBox using VMware tools.

share|improve this answer
The virtual machine now boots up until "Loaded: \Windows\system32\driver\crcdisk.sys" (booting in safe mode). Does this mean I can presume the harddiks type is correct? – Bart Burg May 2 '12 at 12:27
Thank you, this did work! After a long boot, it worked. After the first boot, the boot time is normal. – Bart Burg May 8 '12 at 11:09

You need to delete the Disk controller, Add new SAS Controller and attach to it the Disk Image. It will work! ;)

share|improve this answer
Thanks for the answer, it didn't work though. I still get stuck at "Loaded: \Windows\system32\driver\crcdisk.sys" (booting in safe mode) when booting. – Bart Burg May 2 '12 at 12:29
SAS Controller worked for me when migrating Win2008r2 64bit. No other changes required. – Aoi Karasu Jun 27 '12 at 9:44

I tried both versions mentioned in the question. Unfortunately neither of them worked. In the end, I was successfully able to migrate my VMware VM to VirtualBox using a third approach.

Important! First, I would like to mention that I did this only with test machines and never with a machine used in routine. I would not rely on a migrated VM for routine use.

I successfully migrated two Windows 2008 VMs using the following approach.

  1. Uninstall VMware tools

  2. Create a full clone of the VM to get a clean simple state without any snapshots. As a result, I have a VM with two virtual disk images, one single .vmdk file for each disk (C and D drive).

  3. Create a new VM in VirtualBox without disks (Do not add a virtual hard drive).

  4. Copy the virtual disk image files (vmdk) into the newly created VirtualBox VM folder. If you want, you can rename the disk files. I did that at this point, because, I wanted to have the disk type (C and D) reflected in the file name.

  5. In VMware the disks were connected with a virtual SCSI adapter. The SCSI controller from VirtualBox for some reasons did not work with the virtual disks I had.

  6. Therefore, I did open the settings of the just created VM, and added a IDE controller.

  7. Then, I did choose to add a hard disk, and selected choose existing disk and selected the .vmdk file representing the first disk of the VM. Because, I had two disks, I did repeat this step once for the second disk. You also need to pay attention which on is disk 1 and which one is disk 2. If the OS is on disk 2, the VM will not boot.

  8. Boot the VM. It should boot now. If Windows does not boot, because no BIOS, Windows, etc. found. Try to check, if your first disk is really the system disk.

  9. Install the VirtualBox guest add-ons.

If the two solutions mentioned in the questions do not work for you, you probably want to give this one a try. Good luck!

share|improve this answer

Thanks for information above - this is what worked for me for Windows 2003:

  1. Uninstall VMWare tools when booted in VMWare workstation (I didn't do this on first attempt and I had problems with some services not starting and I was unable to remove VMWare tools when booted under Virtual Box)

  2. Combined vmdk file into 1 file (as vmdk had been created with default of split into files of no more than 2GB). You can use vmware-vdiskmanager for this but I was running out of space on vmdk so I created a new bigger vmdk in VMWare workstation, then booted virtual machine using a Linux Live CD (I used Ubuntu 12.04) and did a dd from old disk to new disk and then I extended partition using gparted (on Linux Live CD) into the unused part of the bigger vmdk.

  3. Ticked "Enable IO APIC" for Extended Features on System-Motherboard on vbox virtual machine - without doing this, the virtual machine would start to boot, but never complete.

  4. I changed vmdk to be under SCSI controller and this is what is was under in VMWare, but I later changed it to under IDE (as Primary Master) and this also worked.

  5. Windows 2003 doesn't have a SAS driver and I wanted to be able to use SAS too, so I installed driver from

  6. Installed virtualbox additions - this resolved base system device driver which had a question mark in Device Manager and installed video driver which allows any resolution video screen which changes as you resize window.

Hope this helps other people.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.