Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently trying to get nginx to work with cgit which uses cgi.
I know nginx doesn't support cgi directly but it appears you can support it indirectly via FastCGIWrap.

The link above is pretty self explanatory but I'm having a problem with compiling the program. What I've done so far:

  1. Installed libfcgi-2.4.0
  2. cd fcgiwrap && autoconf -i
  3. When I run ./configure I get this output

    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for FCGX_Init in -lfcgi... yes
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /usr/bin/grep
    checking for egrep... /usr/bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking limits.h usability... yes
    checking limits.h presence... yes
    checking for limits.h... yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking for unistd.h... (cached) yes
    checking for stdbool.h that conforms to C99... yes
    checking for _Bool... yes
    checking for pid_t... yes
    checking for size_t... yes
    checking for ssize_t... yes
    checking vfork.h usability... no
    checking vfork.h presence... no
    checking for vfork.h... no
    checking for fork... yes
    checking for vfork... yes
    checking for working fork... yes
    checking for working vfork... (cached) yes
    checking whether lstat dereferences a symlink specified with a trailing slash... yes
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible malloc... yes
    checking for strchr... yes
    checking for strdup... yes
    checking for strrchr... yes
    checking for dup2... yes
    checking for putenv... yes
    checking for select... yes
    checking for setenv... yes
    checking for strerror... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: WARNING:  'Makefile.in' seems to ignore the --datarootdir setting
    config.status: error: cannot find input file: config.h.in
    

After this I can't do make -s && make -s install because it can't find config.h.in.
Is there another way to install this on slackware 12.2 or is there any package of it or this program is meant only for Debian/Ubuntu like distros?

Edit: automake returns:

Useless use of /d modifier in transliteration operator at /usr/share/automake-1.10/Automake/Wrap.pm line 60.
configure.ac: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal).
automake: no `Makefile.am' found for any configure output
share|improve this question
    
Try to re-unpack the distro but this time omit autoconf step. –  yarek May 1 '12 at 19:39
    
I'd usually do that but in this case, if you download the archive, you'll see there's no ./configure script. You can't do make && make install because it fails with make: *** No targets specified and no makefile found. Stop. –  tftd May 1 '12 at 19:43
    
then, try doing automake before autoconf. –  yarek May 1 '12 at 19:53
    
Question updated with the result.. –  tftd May 1 '12 at 21:57
1  
Please double-check: in the question you wrote autoconf -i while the instructions ask for autoREconf -i. If yes, then I'd suggest to reach Grzesiek, the author of the package, for his insight. –  yarek May 1 '12 at 23:01

1 Answer 1

up vote 1 down vote accepted

Autoreconf's option -i should generate missing autotool files using library defaults.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.