Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install a newer version of the nokogiri gem (going to 1.5.2 from 1.4.3.1).

The output that i get looks like this:

[~]# gem install nokogiri -v '1.5.2' 
Building native extensions.  This could take a while... 
ERROR:  Error installing nokogiri: 
        ERROR: Failed to build gem native extension. 

        /path/to/rvm/rubies/ruby-1.8.7-p352/bin/ruby extconf.rb 
checking for libxml/parser.h... yes 
checking for libxslt/xslt.h... yes 
checking for libexslt/exslt.h... yes 
checking for iconv_open() in iconv.h... yes 
checking for xmlParseDoc() in -lxml2... yes 
checking for xsltParseStylesheetDoc() in -lxslt... yes 
checking for exsltFuncRegister() in -lexslt... yes 
checking for xmlHasFeature()... no 
----- 
The function 'xmlHasFeature' is missing from your installation of libxml2.
Likely this means that your installed version of libxml2 is old enough that
nokogiri will not work well.  To get around this problem, please upgrade your    
installati on of libxml2. 

This is a RedHat box with RPM v4.3.3, and i'm assuming that libxml2 needs to be updated. It looks like the current version is:

MODULE_VERSION="xml2-2.6.16"

But i'm not familiar with what the upgrade command/process would look like, can you help?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.