Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I bought a Cisco Aironet AIR-AP1231G-A-K9 off of ebay and am having issues with it.

The first and most alarming issue is the cycling of the status lights. I read the manual and it does not show that as a possible state.

Here is a video of the status lights -> https://www.youtube.com/watch?v=ubuBkHCuwWg

It does pull an IP address via DHCP on my Sonicwall, but is unreachable via web browser. I pinned out my own console cable, and nothing comes up over the console when done in accordance with the manual.

I tested the power supply and it is making 47.8vdc, and makes 47.8vdc when under load (connected to the Aironet).

It doesn't appear to be broadcasting an SSID, but of course if it is, it would be easy to miss since I don't know what it is (used unit).

Bad unit?

Thanks for your time.

share|improve this question
    
Have you connected a console cable and/or tried a factory reset? Do you know if it's in LWAPP to Autonomous mode? –  jscott May 2 '12 at 1:00
    
Do those lights flash like that immediately, or after a minute or two. Also, you probably made some type of mistake with the console cable. Whether it's autonomous or lightweight, if it's booted enough to get an IP, you should have console output. –  MDMarra May 2 '12 at 2:07
    
It appears to boot properly, then after about 1.5 post boot minutes they start doing that. And as far as the cable, its a simple db9 to rj45, pretty hard to screw up. I pinned it according to bit.ly/agMuBn –  user1080943 May 2 '12 at 17:35
    
As far as a "reset", all it has is a "mode" button, and I have not read anywhere about resetting without using the console or web interface. Is there a way to reset it physically? –  user1080943 May 2 '12 at 17:37

2 Answers 2

up vote 2 down vote accepted

The continuous blinking lights, although undocumented, were caused by the Aironet not being able to reach the WLC (wireless lan controller). Long story short, it was in LWAPP mode, also known as lightweight mode where it connects to a controller. The key is to get it back into "autonomous mode" (to use as a standalone WAP) via a change in firmware with tftp (see below).

The next issue is that the Cisco pinout for RJ45 to DB9 is incorrect - pin 6 and 3 need to be swapped on the RJ45 to get the communication working.

Lastly, I used the following steps to change the firmware:

Here is the tftp server I used on a windows box - http://tftpd32.jounin.net/

Follow these steps to revert from LWAPP mode to autonomous mode by loading a Cisco IOS release using a TFTP server:

  1. The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.
  2. Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.
  3. Set the timeout value on the TFTP server to 30 seconds.
  4. On the PC where the TFTP server is located, disable any software firewall products (such as Windows firewall, ZoneAlarm firewall, McAffee firewall, or others), and ensure all Windows files are visible. From Windows Explorer, click Tools > Folder Options > View; then uncheck the Hide extensions for known file types check box.
  5. Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point, c1130-k9w7-tar.default for an 1130 series access point, c1240-k9w7-tar.default for a 1240 series access point, and c1250-k9w7-tar.default for a 1250 series access point.
  6. Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.
  7. Disconnect power from the access point.
  8. Press and hold MODE while you reconnect power to the access point.
  9. Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.
  10. 10 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.
  11. After the access point reboots, reconfigure it using the GUI or the CLI.
share|improve this answer

Thank you for taking the time to create such clear instructions. I was able to re-flash my unit using them. A few things I'd like to add for others.

  1. I had a regular blue cisco cable (RJ45 DB9) and that worked. I had no pin problems.
  2. I tried tftp on my Mac using terminal and with a couple different tftp software programs. I had trouble I was not able to resolve. There must be a way however. I ended up successfully using the Windows software mentioned in your post. (Here are some Linux instructions that seem to address the kinds of problems I was running into earlier. http://wozney.ca/2008/12/18/downgrade-from-lightweight-to-autonomous-using-linux/ )
  3. I noticed that holding the mode button on the AP a little longer after the status light turned red gave more time for the ethernet hookup to be found by the tftp software. As soon as that connection was established I released the mode button.
  4. I used Minicom 2.5 on Linux along with the cisco cable and a Windows computer with the ethernet cable and tftp server software. There is a message on the Minicom terminal as the new IOS software uploads to the AP saying the flash area is full. Just do nothing and hang tight and the AP will automatically reformat the flash area and will reload (re-download) everything again. It takes maybe 7-9 minutes for the entire re-flashing process to happen. You need to just sit and watch the log files on the tftp program.

Good luck to everyone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.