Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Seen this question asked a few times, tried out several posted solutions without any luck.

installed phusion passenger w/ nginx, running ruby 1.9.3 under a multi-user rvm install

somewhat familiar with nginx and deployment of python apps through uwsgi -- this one has me stumped

My nginx vhost config is pasted below:

server {
    listen 80;

    server_name EXAMPLE.COM;

    access_log /home/redmine/logs/nginx_access.log;
    error_log /home/redmine/logs/nginx_error.log;
    client_max_body_size 10m;
    keepalive_timeout 120;

    root /home/redmine/redmine-repo/public;
    passenger_enabled on;

}

for reference static files are being served correctly

for example when I try to visit: http://EXAMPLE.COM/images/duplicate.png

it shows up just fine -- I've set the entire /home/redmine directory to chmod -R 0777 /home/redmine

thinking I'm missing something on the config side -- any ideas what I'm missing?

share|improve this question
    
Check your application, show us logs and tell the number error you're getting on your app. –  Dmitry Verkhoturov May 2 '12 at 5:50
add comment

2 Answers 2

If all the folder and file permission are set correctly, please check the configuration under nginx.conf:

location ~ ^/redmine(/.*|$) {
   passenger_base_uri /redmine;
   passenger_app_root /Users/cc/Dropbox/Work/www/redmine;
   passenger_enabled on;
}

You should have at least these three lines to enable redmine to work.

share|improve this answer
add comment
up vote 0 down vote accepted

Silly problem - simple solution once I tracked down the right ference

I had selected to perform a custom install of nginx with passenger when doing so it did not add the

passenger_root
passenger_ruby

variables to nginx.conf so passenger was not being initialized

hope this helps someone running into the same issue

share|improve this answer
    
If this is resolved, please mark it as such. Thanks and welcome to Server Fault. –  Michael Hampton Feb 27 at 2:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.