Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a Debian LAMP Server in VMWare Player, using a bridged connection.

However, on my router the VM is showing up with the same MAC Address... therefore I can't set the VM to a static address.

I've tried changing the MAC in the .vmx, but to no success. I'm not really sure what to do or where to look now. I've tried Googling and I guess I don't know what I'm looking for or I just can't find it, hopefully someone here can help out.

Edit:

Definitely Bridged Connection

Link to Picture - need 15 rep to post pics directly

ARP Table From Ping:

  10.0.0.7              00-1a-73-82-da-c9     dynamic
  10.0.0.10             00-1a-73-82-da-c9     dynamic

7 is the Host OS 10 is the VM

share|improve this question
    
What's the host OS? Are you a superuser there? –  wfaulk May 2 '12 at 3:23
    
Windows 7, yes I'm running as Admin the only account on there. –  mburn7 May 2 '12 at 3:24

2 Answers 2

up vote 1 down vote accepted

It turns out it was a problem with the system running off WiFi. When I used the Ethernet connection, the MAC Address returned to what it should have been.

share|improve this answer
    
It used to be that you couldn't change the MAC address of WiFi adapters. I don't know that that's still the case, but it would explain what you're seeing here. –  wfaulk May 4 '12 at 17:49

What MAC address are you using? If it's not a VMware MAC (00:50:56:...), you have to also include this config option:

ethernetN.addressType = “static” 
share|improve this answer
    
It was something to do with it being on wireless. I switched they physical machine to an ethernet connection and the MACs show up fine. –  mburn7 May 3 '12 at 2:46
    
You should post an answer yourself and accept it, not accept my incorrect answer. –  wfaulk May 3 '12 at 14:23
    
Ok, done. Thank you. –  mburn7 May 4 '12 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.