Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a single mailbox mail server running Dovecot/Postfix and I have two IMAP clients, Thunderbird on the PC and K9 on Android. I keep on receiving this error in my logs even after I change the 'mail_max_userip_connections' variable to 50.

puppet dovecot: imap-login: Maximum number of connections from user+IP exceeded (mail_max_userip_connections=10): user=<admin@domain.net>, method=PLAIN, rip=62.242.90.2, lip=198.29.31.229, TLS

Why does it say that it is set to 10 in the log? Is that hardcoded?

grep -r "mail_max_userip_connections" /etc/dovecot
/etc/dovecot/conf.d/20-managesieve.conf:  #mail_max_userip_connections = 10
/etc/dovecot/conf.d/20-pop3.conf:  #mail_max_userip_connections = 3
/etc/dovecot/conf.d/20-imap.conf:  mail_max_userip_connections = 50

I've restarted dovecot after making the changes but this error is still logged and I can't access the mailbox. Can anyone help me understand why I can't seem to raise the maximum limit?

share|improve this question
1  
Is the shown line inside imap block? –  Khaled May 2 '12 at 8:26

3 Answers 3

up vote 1 down vote accepted

I recently had occasion to change this value, but I changed it in the main config file; in my /etc/dovecot/dovecot.conf it now says:

protocol imap {
  mail_max_userip_connections = 50
}

And it's been honoured; this is using dovecot 2.0.9 on a Centos 6.2 system. I don't know that that's an answer to your question, but I thought it might be useful for you to know that someone else had got it working, and how.

share|improve this answer
    
That seemed to work! Not sure why its not loading /etc/dovecot/conf.d/20-imap.conf, perhaps I need to explicitly define this in some load path. Thanks! –  Michelle May 6 '12 at 13:24

Add mail_max_userip_connections = 50 in the global section, not in protocol imap or protocol pop3 sections. At least after doing so my dovecot -a started to return the requested value for mail_max_userip_connections and not the default 10.

I'm running Dovecot 2.0.9 on CentOS.

share|improve this answer

To me, the answer with the hint to the global section seemed to work.

Changed first only in ./conf.d subdirectory, but that didn't work and the E-Mail client continued in showing the error message as before with the value of 10 max connections. Tried a lot with always restarting the server, but as it was a brand new installation, I had to look into more details.

As this parameter wasn't set before, I inserted it here (dovecot.conf):

    ...

    # Protocols

    mail_max_userip_connections = 100

    !include_try /usr/share/dovecot/protocols.d/*.protocol

    protocol imap {
            mail_plugins = $mail_plugins imap_quota
    }

    ...

May be, the value can be reduced later, but that needs testing as many devices are simultaneously checking for new mails.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.