Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some problem, i have 3 VM (vm1, vm2, and vm3). vm1 is normal. ping to internal and external is OK, DHCP is OK. but vm2 and vm3 very strange. DHCP is OK but can't ping to internal and external. Can't ping to localhost and to gateway ip.

Anyone know to solve this problem ?

Thanks before and after for advance.

share|improve this question
    
Are you sure that DHCP is ok ? Maybe its assigning virtual private adress ? Is it Windows on it (i mean on vm2,vm3) ? –  Alan Kuras May 2 '12 at 13:28
    
yes, continue to my last comments –  user1316095 May 2 '12 at 17:17

1 Answer 1

If you cannot even ping the localhost, then try to ping lo addresss 127.0.0.1 to see if that works. If not your lo interface is not up and you need to fix that. Dhcp working? Does that mean your virtual nic is getting all the network information? What does ifconfig command return by the way.

share|improve this answer
    
yes, DHCP is OK, cause i get an ip address, but can't ping to gateway too. its happen not just in VM, physically too. –  user1316095 May 2 '12 at 17:16
    
what is the ip you got from dhcp? what is your subnet range? –  johnshen64 May 2 '12 at 17:18
    
i think it not VM problem, it linux problem. I use CentOS 5.7 final. –  user1316095 May 2 '12 at 17:19
    
ip is 10.103.104.3 netmask is 255.255.255.0 GW is 10.103.104.1 –  user1316095 May 2 '12 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.