Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a lot of difficulty with this seemingly simple problem.

All I want to do is mount an NFS directory over a private network.

I've checked the exportfs from the exporting side and it is reporting correctly that it's exporting the desired directory to the proper IP address.

Here are my files for autofs

auto.master:

/home  -fstype=nfs  /etc/auto.misc

auto.misc:

myWork   -ro,intr   [IP]:/usr/local/share/myWork

The drive simply isn't showing up when I look for it, I do get this log, but don't know what to make of it.

Jul 9 14:20:37 localhost automount[9538]: lookup_mount: lookup(nisplus): key "myWork" not found in map

I have ensured that both NFS and autofs are running by checking their respective status.

Let me know if this is enough info or if there are other things I can do to diagnose the problem.

As you may notice, this is my first foray into mounting and the server environment, so take it easy on me.

EDIT: Needed a newline at the end of auto.misc... Zoredache has good suggestions for others with a similar problem below

share|improve this question
    
Perhaps a silly question, but are you able to manually mount the NFS filesystem? –  Zoredache Jul 9 '09 at 18:53
    
not a silly question, the drive is manually mountable, so I'm leaning towards the fact that I'm missing something in the autofs configuration –  Evan Jul 9 '09 at 18:59
add comment

3 Answers 3

Your auto.master file doesn't need the -fstype

It should just be something like this:

/home  /etc/auto.misc
share|improve this answer
add comment

On Debian/Ubuntu systems autofs comes with a executable mount map call /etc/auto.net. I am not sure if the same file is available on centos. That mount map automagically handles nfs. I suggest you use that if possible, since it is more flexible then manually specifying everything.

So I setup the my nfs mounts like this

/etc/auto.master

/net    /etc/auto.net --timeout=180

So if I have shared /home on the host named enterprise I simply access those files by looking in /net/enterprise/home/. I create symlinks into the /net/host/path where I need things to show up.

share|improve this answer
1  
I wasn't using auto.net because I had seen so many people claiming it buggy...turns out I left a newline out from the end of one of my config files \facepalm –  Evan Jul 9 '09 at 19:20
    
It does have bugs in a few situations e.g. if you have complex exports on your servers. But this isn't an issue for me. –  Zoredache Jul 9 '09 at 19:26
add comment

(curious) is there a reason your using autofs over editing your fstab file?

We have 3 frontend webservers that mount a config directory & web storage directory from our NFS NAS-Heads, just using the following lines in our /etc/fstab file.

10.0.32.151:/var/storage/conf        /etc/httpd/conf nfs     rw      0       0
10.0.32.151:/var/storage/html        /var/www/html   nfs     rw      0       0

Edit: We're running CentOS 5 as well.

share|improve this answer
    
did some research : autofs has lower overhead, interesting. Might need to do some research & implement this on our servers. –  GruffTech Jul 9 '09 at 23:27
    
yep, we actually ended up using fstab since there was only one mount...but with multiple mounts it can become a good idea to use autofs as fstab can become resource intensive –  Evan Jul 21 '09 at 19:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.