Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install and configure an OpenAFS server inside an OpenVZ container. However, when running afs-newcell, it complains that the AFS client cannot be started. It says "AFS module /lib/modules/2.6.32-5-openvz-amd64/fs/openafs.o does not exist."

In the host, I installed openafs-modules-2.6.32-5-openvz-amd6 (from MIT). Doing lsmod | grep afs on host works, and show that openafs module is loaded. Doing the same in the guest doesn't show the module.

I understand that modprobe cannot be run inside a container for stability and security reason, but is there any way of "sharing" some module with a specified guest?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The easiest solution is to stop using afs-newcell and just configure the AFS server manually.

afs-newcell wants your server to also be an AFS client. It's doing this because it's going to be helpful when setting up a brand new cell and create your root.afs and root.cell volumes and populate root.afs with the contents of your CellServDB file. But all of that is to some extent optional, and more to the point, can be done from some other AFS client. You don't need to do all of that inside your OpenVZ container, and probably don't want to go to the work of figuring out how to make afs-newcell believe that it's a client.

The only really tricky thing that afs-newcell does is to run pt_util to create the initial ptserver database. I would just follow the normal AFS server setup instructions rather than trying to use the script.

Note that if this is a server for an existing cell, as opposed to setting up a brand new AFS cell, you don't want to be using afs-newcell at all. It's only for setting up the first server in a completely new cell.

share|improve this answer
    
Hi, I've tagged your answer as accepted because it probably would have fixed my issue :). However, I cannot test it because I don't run this configuration anymore. –  Xaqq May 13 '13 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.