Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I manage an AIX box at work using PuTTY. I'm using ksh in vi-mode. When I press the Delete key (not backspace) the case of following characters is toggled instead of the character under the cursor being deleted. I'm not necessarily looking to change the behavior, as this is a very important server and I just don't want to make unnecessary changes, but I would like to understand why it's happening.

Steps to reproduce.

  1. Type some text:
    root:common> ls -al
  2. Move the cursor over the dash. ([esc] hhh)
  3. Press the Delete Key. ([del])
  4. Strange things happen:
    root:common> ls -AL

Expected behavior: The character under the cursor is deleted.

Actual behavior: Following characters have their case toggled.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

That's the default behavior in ksh vi-mode. I suggest that if you want to erase try "x" key, as this is the correct key to delete a character in vi-mode. Also "X" will delete a key just before the one selected.

share|improve this answer
    
So, what is it that the delete key is actually doing? It seems like it must be a different command that I just don't understand. –  bshacklett May 23 '12 at 13:09

It sounds like the AIX server has different definitions for scancodes from the computer you are running putty from, and when you type delete it sees it as caps lock. If you "fix" this on the server you may find the local keyboard doesn't operate as expected. However, you can experiment with the putty keyboard settings (maybe change the home and end keys to rxvt, or the function keys and keypad to VT400).

share|improve this answer

If you are connecting to AIX 6 or AIX 7 check the following under your putty connection settings:

Category ==> Terminal ==> Keyboard

Set:

The Backspace key to the "Control-H" option

The Function keys and keypad to "XtermR6"

The "term" definitions & mapping used by AIX changed from AIX 5 to AIX 6+.

I am using these putty session on AIX 6.1 TL7 & AIX 7.1 TL1. I use the default settings for AIX 5.3.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.