Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Everything was working fine until this moment I want to create a new database and I'm receiving this error

db_create.php: Missing parameter: new_db (FAQ 2.8)

Also when I was trying to export my database I also receive the following error

export.php: Missing parameter: what (FAQ 2.8)
export.php: Missing parameter: export_type (FAQ 2.8)

When I looked it FAQ 2.8 from the suggested link in PHPMYADMIN

2.8 I get "Missing parameters" errors, what can I do?

Here are a few points to check:

  • In config.inc.php, try to leave the $cfg['PmaAbsoluteUri'] directive empty. See also FAQ 4.7.
  • Maybe you have a broken PHP installation or you need to upgrade your Zend Optimizer. See http://bugs.php.net/bug.php?id=31134.
  • If you are using Hardened PHP with the ini directive varfilter.max_request_variables set to the default (200) or another
    low value, you could get this error if your table has a high number
    of columns. Adjust this setting accordingly. (Thanks to Klaus
    Dorninger for the hint).
  • In the php.ini directive arg_separator.input, a value of ";" will cause this error. Replace it with "&;".
  • If you are using Hardened-PHP, you might want to increase request limits.
  • The directory specified in the php.ini directive session.save_path does not exist or is read-only.

I did tried with php.ini to make sure that I've session.save_path = "/tmp"

I'm using Mac Xserver and running with MAMP I did tried everything to restart my server and nothing help.

Please if anyone help me to give me some suggestion.

Apologize if I post in a wrong place.

share|improve this question
    
So what about the other five recommendations in that FAQ item? –  womble May 2 '12 at 22:17
    
Hi @womble, I couldn't find the config.inc file in my Mac, and number 2 I don't think that is related server and for the rest I can't figure it out how :/ –  Ali May 2 '12 at 22:30
    

2 Answers 2

Please check available space and permissions on your mysql datadir location.

To further isolate the cause, try to create the database from the mysql command line. If this fails, it's mysql problem, not phpMyAdmin's.

share|improve this answer

Take a look if you have permissions at directory configured at session.save_path on php.ini. Probably you changed the Apache user/group and there's no permission for this directory.

To solve: 1) chmod 777 at directory (this is unsecure) OR 2) change the directory owner to match with Apache needs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.