Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have problem with the setting up the Exchange 2010. It's first time for me. What i have to do: We have server with web server on it and we have exchange and domain there (company.xx). I created an USER and a mailbox for this user (user@company.xx). Due to other (sub)domain on other server we added next Accepted Domain (copmany.otherdomain.xx) and added next mail address for the USER (user@copmany.otherdomain.xx).

When I'm trying to send email to this USER "user@copmany.otherdomain.xx" i recieve Undelivered Mail msg: 550 5.1.1 RESOLVER.ADR.RecipNotFound; not found

The MX and A records on the other server are set up correctly. I see the incoming emails in Message Tracking Result on our Exchange server, but i don't know, what to do for the receiving mails in USER's mailbox.

Maybe it's really stupid question, but i was looking for answer without success.

Thank you very much for any help.

Best Regards, Václav


Problem solved: added E-mail Address Policies

Now i will try to set up a Catch-All agent or something similar for bad e-mail adresses.

share|improve this question
    
Are you using an Edge Transport server in your network? –  Chris McKeown May 2 '12 at 22:56
    
No we aren't, I couldn't find Edge Trasport setting in Hub Transport, I looked for any help and found it, so I tried to install Edge Trasport via MX installer, but this options was gray. I can't install it. Now i added address policies from answer bellow and it works - for known emails. Now i'm going to solve problem with catch-all settings. –  Washa May 3 '12 at 14:23

1 Answer 1

up vote 0 down vote accepted

From your question, it sounds like you have not added the domain to the Exchange Server as an Authoritative Domain for your Exch2010 Org Config, or added an email policy.

Open the Exch 2010 EMC, expand the Organization Configuration, and select Hub Transport (oh yeah, do this on a hub server, not an edge server). Select the "accepted domains" tab, and on the right-hand panel, select "new accepted domain". Then give the domain a common name and enter the FQDN for the otherdomain.xx domain.

Next, click the tab for email address policies in the same section, and select "new email address policy". Give it a common name, hit next, then if you want the policy to apply to everyone in AD, simple leave the next screen as is. You can specify having the email policy only apply to certain AD users by setting custom attributes on users and then selecting that attribute here, if you so desire.

Hit next, hit Add by the green + sign, and then you can define how the email addresses will be generated (alias, fn/ln, fi/ln, etc), then, just to make sure you entered it right as a accepted domain, you can select the radio button for "select the accepted domain for the email address", hit browse, and see if the domain you added is there.

Hit next, then hit next to apply immediately (or set a schedule for later).

share|improve this answer
    
Thank you for help. I didn't know, that i have to do it. Now it works. The second phase will be to set the catch-all for unknown addresses on our domain. (if someone makes a mistake in the address). –  Washa May 3 '12 at 14:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.