Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Normally sudo apt-get install gets me what I want with no issues, it installs dependencies and takes away a lot of the hassle. For some reason it's stopped working now.

$ sudo apt-get install libssl0.9.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libssl0.9.8: Depends: libc6 (>= 2.7) but 2.6.1-1ubuntu10 is to be installed
E: Broken packages

It seems like it's having trouble installing libc6 which it depends on, but when I run apt-get install libc6 it tells me it's installed and up-to-date.

I having similar issues with installing openssl.

I've tried running apt=get update but that didn't help.

share|improve this question
    
Dare I ask which version of Ubuntu you're on? libc6 2.6.1-1ubuntu10 appears to be from the positively ancient Ubuntu 7.10, which has been unsupported for over 3 years. If so, I expect that apt-get update is throwing errors instead of actually doing anything. Is that the case? –  Shane Madden May 3 '12 at 5:51
    
That's exactly right. I've checked to make sure the sources list contains gutsy gibbon and it does, but still throws errors when I run update –  Richard May 3 '12 at 6:24
    
Have you changed release in your sources.list file? I haven't seen a dependency problem like that since I foolishly started to install Debian sarge packages on a woody box. –  SmallClanger May 3 '12 at 8:32
    
No as I think doing this would force an upgrade and potentially give me more problems? –  Richard May 3 '12 at 8:35

2 Answers 2

I'm not an expert on this, but it seems that the issue is that the packages aren't supported anymore (even the old-releases server).

After a lot of research (I'm doing this on a remote server over SSH so can't have any issues) the following quite seems helpful:

Upgrade Gutsy

Also there's a more general guide here for upgrading all the way back from Breezy 5.10 up to the latest version here

share|improve this answer
    
Yup - getting yourself onto Hardy is probably the best course of action at this point. –  Shane Madden May 3 '12 at 14:40

You need to do an apt-get upgrade, not cherry pick libssl, as it depends on a newer version of libc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.