Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The following command:

icacls c:\inetpub\wwwroot\ /grant "IIS AppPool\DefaultAppPool":F

Constantly returns

Invalid parameter "IIS AppPool\DefaultAppPool"

For any app pool name on any folder, I'm running this from powershell as admin.

I'm sure this has worked before?

Any suggestions much appreciated!

Dan

share|improve this question
    
I am having the same issue, it doesn't seem to matter what apppool i enter. I even tried importing the WebAdministration snapin just to see if it was path related to IIS: Please let me know if you find anything –  user123808 Jun 6 '12 at 19:32

1 Answer 1

up vote 0 down vote accepted

You need to wrap the whole of the grant argument in quotes:

icacls c:\inetpub\wwwroot\ /grant "IIS AppPool\DefaultAppPool:F"
share|improve this answer
    
I don't actually recall what site/server we were having this issue with but this sounds like this would have very likely been the answer and I'll know what to check next time :) –  DannyT Aug 9 '12 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.