Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have solaris 10 sparc running and working very well but i have problem with external SCSI tape drive DAT 72 problem it seems to me the tape drive is manufactured by SUN microsystems when i ran mt -f /dev/rmt/0 status it reveals the following output

bash-3.00#  mt -f /dev/rmt/0 status
/dev/rmt/0: No such file or directory

when i ran ls -l it reveals the following output

ls -l /dev/rmt/0
lrwxrwxrwx   1 root     root          43 Sep 20  2006 /dev/rmt/0 -> ../../devices/pci@8,600000/scsi@1,1/st@3,0:

it seems to me everything is okay SCSI cable is connected properly to Tape device and to server as well the tape has SCSI termination dongle as well and connected properly to Tape device as well any ideas would be a great assist Thanks in advance

share|improve this question
What do you get with "mt -t /dev/rmt/0n status" ? – Adam Brand Jul 9 '09 at 20:52
Please make sure that's just a typo in your post mt -t /dev/rmt/0n status does mt has a -t switch on solaris if not please confirm anyways i ran it still getting same msg bash-3.00# mt -t /dev/rmt/0n status /dev/rmt/0n: No such file or directory – Hassan Jul 9 '09 at 23:23

When you look at the symlink destination "/devices/pci@8,600000/scsi@1,1/st@3,0:" does that exist.

share|improve this answer

sorry for inconvenience the instance number for external tape is 1 not 0

it works now very fine

bash-3.00# mt -f /dev/rmt/1 status
HP DAT-72 tape drive:
   sense key(0x6)= Unit Attention   residual= 0   retries= 0
   file no= 0   block no= 0
share|improve this answer
# cfgadm -al 
Ap_Id                          Type         Receptacle   Occupant     Condition
c3                             scsi-bus     connected    configured   unknown
c3::rmt/8                      tape         connected    configured   unknown

last entry means that a tape drive is available, the device is : /dev/rmt/8

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.