Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

These is hopefully a pretty simple question. I have an ESXi host, and I would like to use virtual switch vlan tagging. I have set up my cisco switch like this:

interface GigabitEthernet1/0/43
 description bcv-pe-esx02 Virtual Host
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 250,800,810,825
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
end

Now, my hope was to have the actual management interface that I connect to for management with vsphere reside inside one of those vlans, specifically vlan 800. I configured the management interface to be an IP in that vlan, and I set the vlan to 800 in the console. However I cannot ping the IP. Does the management IP need to reside in the native vlan for this setup? I am assuming I am missing something silly in this configuration.

EDIT: Fixed to show current config.

share|improve this question
1  
Your switchport access vlan 250 line is not applicable when the port mode has been changed to trunk. –  brent May 3 '12 at 15:13
    
Ack, sorry, that has been removed already. –  Matthew May 3 '12 at 15:14
1  
When you applied the management IP via console, did you allow ESXi to restart the management network? Does the ESXi network test succeed? –  brent May 3 '12 at 15:17
    
Yup! I think I found the issue, I had two NICs connected and set up as management interfaces. I shut off the second on at the switch level and now I can connect without any problems. That must have been it. Thank you for the help! –  Matthew May 3 '12 at 15:20
    
Cool, you found your bug. Also, you should leave CDP enabled and also configure your vSwitch to work both way (advertise/listen), it make debugging the infrastructure easier. –  CloudWeavers May 3 '12 at 15:44
add comment

1 Answer

That configuration should work fine, I've done exactly that before. On the console, make sure the management traffic is being tagged to the correct vlan.

Check the switch's MAC address table to see if the management interface is communicating via the correct vlan.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.